RubyMine 2017.1.2 EAP 发布:改进 Puppet 模块的检测

两味真火
 两味真火
发布于 2017年04月15日
收藏 0

最近我们刚更新了 RubyMine 2017.1.1 稳定版本,请务必进行更新,因为该版本修复了一个痛苦的  RSpec 回归问题,以及性能问题和其他的一些 bug 。而现在,RubyMine 2017.1.2 EAP 发布了。

RubyMine 是一个全新的为 Ruby 和 Rails 开发者准备的 IDE (非开源且收费),RubyMine 由 JetBrains 开发(JetBrains最著名的产品之一就是 Java IDE:IntellJ IDEA了!)。RubyMine 是建立在 IntellJ IDEA 平台之上,提供所有必须的 IDE 功能,比如编辑,调试工具,源代码控制集成,代码自动提示完成,以及其他功能。专门为 Ruby 打造的功能有基于 GUI 支持的 RSpec 和 Test::Unit。主要更新内容如下:

Puppet 改进:

许多人抱怨更新到v2017.1后,Puppet停止支持他们2016.3.*版本的工作,这使得用户降级到以前的版本。这个EAP会解决这些问题:使用此EAP RubyMine可以从environment.conf读取modulepath。但请注意,您应该在正在处理的项目中使用environment.conf,否则RubyMine将无法检测到它。

修复错误:

  • regression that affected resolution of require calls containing “.” has been fixed.

  • Newly created RVM gemsets now get fetched properly.

  • Fixed the inability to open or create *.php.erb files in IntelliJ IDEA with simultaneously active PHP and Ruby plugins.

  • Fixed previously broken Go to implementation in Cucumber.

完整更新信息请查看更新日志

下载地址:RubyMine 2017.1.2 EAP (build 171.4249.6) 

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:RubyMine 2017.1.2 EAP 发布:改进 Puppet 模块的检测
加载中
返回顶部
顶部