jQuery 3.2.1 发布,Bug 修复版本

局长
 局长
发布于 2017年03月21日
收藏 3

jQuery 3.2.1 发布了,这个版本包括一些修补程序,用于在 4 天前在 3.2.0 版本中引入的回归。官方也希望可以尽快发布这个补丁程序,以减少在升级时遇到的任何错误。最重要的一点是检索没有显式设置尺寸的内联元素的宽度或高度。现在应该会正常工作。下面提供了完整的更改列表。也可以参阅 3.2.0 的博客帖子以了解修复的错误和改进。

如果尚未升级到 jQuery 3+,请查看 3.0 升级指南jQuery Migrate 3.0 插件将帮助你识别代码中的兼容性问题。

变更

Core

Dimensions

  • Ensure we get proper values for width and height on elements with display “inline” (#3571473d2ea7)

Event

  • Ensure trigger data is passed to radio click event handlers (#3579a6b07052)

  • Revert: Trigger checkbox and radio click events identically (35785a32).

  • Revert: Add radio click triggering tests (4d6b4536).

GitHub changelog: Issues fixed in 3.2.1 | All changes

发布主页

下载

也可从 npm 获取:

npm install jquery@3.2.1

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:jQuery 3.2.1 发布,Bug 修复版本
加载中

精彩评论

南漂一卒
南漂一卒

引用来自“EayonChioa”的评论

我操,可到3了,我TMD还在用1!

引用来自“iehyou”的评论

3是移动优先版 还是乖乖用1吧。
官方没说是“移动优先”,只是只支持 IE 9 及以上版本浏览器~

最新评论(9

else
else
计划着,把项目改成3.2
南漂一卒
南漂一卒

引用来自“EayonChioa”的评论

我操,可到3了,我TMD还在用1!

引用来自“iehyou”的评论

3是移动优先版 还是乖乖用1吧。
官方没说是“移动优先”,只是只支持 IE 9 及以上版本浏览器~
w
weiwei.deng
什么鬼呀....都 3.0拉
沧海一刀
沧海一刀
jquery 1.1.2如果
锟铻科技
锟铻科技
我也还在用1,还是1.7.1版本~醉了
我叫程序猿不叫码农
我叫程序猿不叫码农
1.8.3的路过
iehyou
iehyou

引用来自“EayonChioa”的评论

我操,可到3了,我TMD还在用1!
3是移动优先版 还是乖乖用1吧。
糖糖小公主
糖糖小公主
我操,可到3了,我TMD还在用1!
返回顶部
顶部