KoaHub.js 更新,Node.js Web 快速开发框架

einsqing
 einsqing
发布于 2017年03月14日
收藏 30

KoaHub.js -- 中文最佳实践Node.js Web快速开发框架。支持Koa.js, Express.js中间件,可以直接在项目里使用 ES6/7(Generator Function, Class, Async & Await)等特性,借助 Babel 编译,可稳定运行在 Node.js 环境上。

1.【新增】新增测试代码,目前覆盖率达93%

2.【新增】新增支持express中间件,默认支持koa中间件

3.【新增】新增目前仅支持node7.6+环境

...

koahub.js入门视频教程, 网盘:https://pan.baidu.com/s/1mi0TaFu(录的不好,还望海涵)

koahub.js简单cms,https://github.com/koahubjs/koahub-simple-cms

koahub.js微信商城系统,https://www.koahub.com/home/product/60

koahub.js官网, http://js.koahub.com

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:KoaHub.js 更新,Node.js Web 快速开发框架
加载中

最新评论(8

einsqing
einsqing

引用来自“hantsy”的评论

Node 7.5 本身就完整支持 ES6 了, 为什么还需要 Babel 编译。

引用来自“非良”的评论

import 这种还不支持吧.
还不支持,不过koahub-cli可以根据node环境去编译代码支持。
einsqing
einsqing

引用来自“water6000”的评论

一年后 ,就不支持了嘛?没看懂你官方网站上的说明????
现在支持6.0.0以上,因为koa上个版本最低支持7.6,这个版本又降回来了,我们跟他保持一致就出现了这个情况。
wx---每日佳选
wx---每日佳选

引用来自“hantsy”的评论

Node 7.5 本身就完整支持 ES6 了, 为什么还需要 Babel 编译。
import 这种还不支持吧.
好心眼
好心眼

引用来自“water6000”的评论

node 6.10就不支持了吗?
回复@water6000 : 还有呢
water6000
water6000
node 6.10就不支持了吗?
water6000
water6000
一年后 ,就不支持了嘛?没看懂你官方网站上的说明????
einsqing
einsqing

引用来自“hantsy”的评论

Node 7.5 本身就完整支持 ES6 了, 为什么还需要 Babel 编译。
可以不用使用babel,有的人喜欢esmodule,所以必须得babel
hantsy
hantsy
Node 7.5 本身就完整支持 ES6 了, 为什么还需要 Babel 编译。
返回顶部
顶部