ActFramework 1.0.2 发布, Java MVC 框架

罗格林
 罗格林
发布于 2017年03月13日
收藏 9

ActFramework 1.0.2 发布了,改进内容包括:

act-1.0.2

  • Fix # 88 Controller context break with intermediate non-controller class in the hierarchies

  • Fix #87 DependencyInjectionListener shall register with sub classes of the target class also

  • Fix #86 It shall allow null value for enum type parameter when do the request parameter binding

  • Fix #83 Hot reload will not process changes to messages resource bundles

act-morphia-1.0.1

  • Fix #4 MorphiaInjectionListener not effect on User defined Dao

act-ebean-1.0.1

  • Fix #1 EbeanDao.drop() method cause JdbcSQLException

  • Fix #3 EbeanInjectionListener not effect on User defined Dao

act-aaa-1.0.1

  • Fix #1 It shall not throw out NPE when AAA service cannot find the user in the system

点此查看详细信息和错误修正链接

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:ActFramework 1.0.2 发布, Java MVC 框架
加载中

精彩评论

VilenEera
VilenEera
正学习试用中 😄

最新评论(15

啵啵君--火星IT男
啵啵君--火星IT男
写得不错,继续加油!这里再补充一下.http://www.marsitman.com/springboot/springboot_hot_deploy.html
shuaia
shuaia
热部署,666
罗格林
罗格林

引用来自“love_001”的评论

maven依赖包存在告警
[WARN] The POM for com.google.zxing:javase🏺3.3.0 is invalid, transitive dependencies (if any) will not be available
[WARN] The POM for io.undertow:undertow-core🏺1.4.11.Final is invalid, transitive dependencies (if any) will not be available
导致依赖类缺失,示例运行出错。

引用来自“罗格林”的评论

@love_001 , 具体的示例运行出错信息是什么?

我刚刚更新了TechEmpower的测试项目到1.0.2版(https://github.com/TechEmpower/FrameworkBenchmarks/pull/2590)

他的Build都是成功的呢.这里是log:

https://travis-ci.org/TechEmpower/FrameworkBenchmarks/jobs/210517617


引用来自“love_001”的评论


Caused by: java.lang.ClassNotFoundException: org.xnio.Pool
  at java.lang.ClassLoader.findClass(ClassLoader.java:530)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
  at act.boot.app.FullStackAppBootstrapClassLoader.loadClass(FullStackAppBootstrapClassLoader.java:291)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
  ... 10 more
运行提示的是找不到类

引用来自“罗格林”的评论

这个类是undertow的.收到这个错误说明你的依赖没有下载完整. 感觉有可能是你的网络访问maven中央库的问题. 国内有人使用阿里云的Maven库. 你可以尝试一下

引用来自“love_001”的评论

确定了是<undertow.version>1.4.11.Final</undertow.version>
的问题 使用<undertow.version>1.4.10.Final</undertow.version> 这个版本没有问题,maven仓库和阿里仓库都存在同样的问题。
应该是你下载1.4.11.Final的时候出现了问题. 你可以清理相关本地缓存, 比如: `rm -rf ~/.m2/repository/io/undertow/ && rm -rf ~/.m2/repository/org/jboss/xnio` 然后再试试
love_001
love_001

引用来自“love_001”的评论

maven依赖包存在告警
[WARN] The POM for com.google.zxing:javase🏺3.3.0 is invalid, transitive dependencies (if any) will not be available
[WARN] The POM for io.undertow:undertow-core🏺1.4.11.Final is invalid, transitive dependencies (if any) will not be available
导致依赖类缺失,示例运行出错。

引用来自“罗格林”的评论

@love_001 , 具体的示例运行出错信息是什么?

我刚刚更新了TechEmpower的测试项目到1.0.2版(https://github.com/TechEmpower/FrameworkBenchmarks/pull/2590)

他的Build都是成功的呢.这里是log:

https://travis-ci.org/TechEmpower/FrameworkBenchmarks/jobs/210517617


引用来自“love_001”的评论


Caused by: java.lang.ClassNotFoundException: org.xnio.Pool
  at java.lang.ClassLoader.findClass(ClassLoader.java:530)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
  at act.boot.app.FullStackAppBootstrapClassLoader.loadClass(FullStackAppBootstrapClassLoader.java:291)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
  ... 10 more
运行提示的是找不到类

引用来自“罗格林”的评论

这个类是undertow的.收到这个错误说明你的依赖没有下载完整. 感觉有可能是你的网络访问maven中央库的问题. 国内有人使用阿里云的Maven库. 你可以尝试一下
确定了是<undertow.version>1.4.11.Final</undertow.version>
的问题 使用<undertow.version>1.4.10.Final</undertow.version> 这个版本没有问题,maven仓库和阿里仓库都存在同样的问题。
罗格林
罗格林

引用来自“love_001”的评论

maven依赖包存在告警
[WARN] The POM for com.google.zxing:javase🏺3.3.0 is invalid, transitive dependencies (if any) will not be available
[WARN] The POM for io.undertow:undertow-core🏺1.4.11.Final is invalid, transitive dependencies (if any) will not be available
导致依赖类缺失,示例运行出错。

引用来自“罗格林”的评论

@love_001 , 具体的示例运行出错信息是什么?

我刚刚更新了TechEmpower的测试项目到1.0.2版(https://github.com/TechEmpower/FrameworkBenchmarks/pull/2590)

他的Build都是成功的呢.这里是log:

https://travis-ci.org/TechEmpower/FrameworkBenchmarks/jobs/210517617


引用来自“love_001”的评论


Caused by: java.lang.ClassNotFoundException: org.xnio.Pool
  at java.lang.ClassLoader.findClass(ClassLoader.java:530)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
  at act.boot.app.FullStackAppBootstrapClassLoader.loadClass(FullStackAppBootstrapClassLoader.java:291)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
  ... 10 more
运行提示的是找不到类
这个类是undertow的.收到这个错误说明你的依赖没有下载完整. 感觉有可能是你的网络访问maven中央库的问题. 国内有人使用阿里云的Maven库. 你可以尝试一下
love_001
love_001

引用来自“love_001”的评论

maven依赖包存在告警
[WARN] The POM for com.google.zxing:javase🏺3.3.0 is invalid, transitive dependencies (if any) will not be available
[WARN] The POM for io.undertow:undertow-core🏺1.4.11.Final is invalid, transitive dependencies (if any) will not be available
导致依赖类缺失,示例运行出错。

引用来自“罗格林”的评论

@love_001 , 具体的示例运行出错信息是什么?

我刚刚更新了TechEmpower的测试项目到1.0.2版(https://github.com/TechEmpower/FrameworkBenchmarks/pull/2590)

他的Build都是成功的呢.这里是log:

https://travis-ci.org/TechEmpower/FrameworkBenchmarks/jobs/210517617



Caused by: java.lang.ClassNotFoundException: org.xnio.Pool
  at java.lang.ClassLoader.findClass(ClassLoader.java:530)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
  at act.boot.app.FullStackAppBootstrapClassLoader.loadClass(FullStackAppBootstrapClassLoader.java:291)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
  ... 10 more
运行提示的是找不到类
罗格林
罗格林

引用来自“love_001”的评论

maven依赖包存在告警
[WARN] The POM for com.google.zxing:javase🏺3.3.0 is invalid, transitive dependencies (if any) will not be available
[WARN] The POM for io.undertow:undertow-core🏺1.4.11.Final is invalid, transitive dependencies (if any) will not be available
导致依赖类缺失,示例运行出错。
@love_001 , 具体的示例运行出错信息是什么?

我刚刚更新了TechEmpower的测试项目到1.0.2版(https://github.com/TechEmpower/FrameworkBenchmarks/pull/2590)

他的Build都是成功的呢.这里是log:

https://travis-ci.org/TechEmpower/FrameworkBenchmarks/jobs/210517617


love_001
love_001
maven依赖包存在告警
[WARN] The POM for com.google.zxing:javase🏺3.3.0 is invalid, transitive dependencies (if any) will not be available
[WARN] The POM for io.undertow:undertow-core🏺1.4.11.Final is invalid, transitive dependencies (if any) will not be available
导致依赖类缺失,示例运行出错。
codingo
codingo
不错哦 mark
talent-tan
talent-tan
把代码放到开源中国,你以后会很忙😂
返回顶部
顶部