IntelliJ IDEA 2017.1 EAP,改进对 Spring 的支持

局长
 局长
发布于 2017年01月18日
收藏 14

IntelliJ IDEA 2017.1 EAP 发布了。在该版本中,除了通常的 bug 修复,还带来了一些相当有趣新奇的东西。

Docker 插件现在支持 Mac 版的 Docker (通过 “unix://”)。对 Windows 的支持 (通过 “npipe://”) 依然有一定的限制

随着对 Spring MVC 路径属性的编码支持,对 Spring 的支持正变得越来越好:

支持对 Spring 的测试(至 Spring 5.0)和 Spring Boot Testing(测试运行和检查):

最后同样重要的是,已解决在 OS X 上与 Korean, Chinese 以及 Japanese 键盘布局相关的问题。

发布主页

下载地址:https://www.jetbrains.com/idea/download/

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:IntelliJ IDEA 2017.1 EAP,改进对 Spring 的支持
加载中

精彩评论

石头捡到布
石头捡到布
我想吐槽的是,项目文件夹的颜色变成了银色之后,真的丑! 而且一般人也不能直接看出来是个文件夹
cooliean
cooliean
还不能XX ,还是先不安装了。
我爱娃哈哈
我爱娃哈哈

引用来自“游客”的评论

😳图上用的什么字体?

引用来自“忆往昔思未来丶”的评论

同问
Fira Code😄
Wizzer
Wizzer
正在搭 spring mvc + nutz 开发框架

最新评论(38

月湾月弯
月湾月弯
感觉很不错。。。。。。。。。。。。。。。
cwwcn
cwwcn

引用来自“游客”的评论

😳图上用的什么字体?

引用来自“忆往昔思未来丶”的评论

同问

引用来自“愤怒的小兔”的评论

好像是Adobe 的 Source Code Pro
不知道什么字体 反正不是Source Code Pro
cwwcn
cwwcn
HTML静态页面中,<div></div>中加上<script type="text/plain"></script>就导致代码大面积的冒红,但是功能还照用,就是冒红色,很不爽!
错误大多提示expression expected。
到底是怎么回事呢?求解决方案!感谢
cwwcn
cwwcn

引用来自“cooliean”的评论

还不能XX ,还是先不安装了。
其实可以的
哎码
哎码

引用来自“cooliean”的评论

还不能XX ,还是先不安装了。
XX是什么?
Jerry-hu
Jerry-hu
更新完,导入和打开项目就一直报错

with(0) and height(0) cannot be <= 0
朋也
朋也
社区版开发springboot,完全没压力
雨翔河
雨翔河

引用来自“ak_birdofprey”的评论

不求好玩,想要个全语言的本地化自由开源IDE。ECLIPSE需要努力一下下

引用来自“雨翔河”的评论

为什么要全语言?英语足矣,java翻译成爪哇吗,哈哈哈

引用来自“ak_birdofprey”的评论

回复@雨翔河 : 我的意思计算机编程的主流语言
sorry,这个难度颇高啊,体积就大了
晒太阳的小猪
晒太阳的小猪

引用来自“ak_birdofprey”的评论

不求好玩,想要个全语言的本地化自由开源IDE。ECLIPSE需要努力一下下

引用来自“雨翔河”的评论

为什么要全语言?英语足矣,java翻译成爪哇吗,哈哈哈
回复@雨翔河 : 我的意思计算机编程的主流语言
jay_
jay_

引用来自“jay_”的评论

哎 公司里面没权限装软件 只能用回预装的Eclipse 😭

引用来自“青木河”的评论

什么公司?这么严格?
平安。。。
返回顶部
顶部