CmlPHP V2.7.2,快速稳定易维护的 PHP 框架

雨空
 雨空
发布于 2016年11月17日
收藏 7

CmlPHP V2.7.2 发布了,本次发布主要更新如下:

  • \Cml\Http\Request::curl文件上传兼容php5.5+版本curl_file_create及老版本@的方式

  • 环境类型获取组件化.若系统自带的development/cli/product配置分层方式不满足要求,可自定义实现

  • 默认路由从url映射到文件的应用层级可通过配置项: route_app_hierarchy=>1,来修改。即应用n层*控制器n层来处理复杂的业务分层

  • 控制器后缀支持自定义配置.默认还是Controller

  • mysql支持关闭数据缓存

CmlPHP 是基于php5.3+(v2.7+要求php5.4+)版本(已经测试过php7)开发的MVC/HMVC/MVSC/HMVSC框架,支持composer、分布式数据库、分布式缓存,支持文件、memcache、redis、apc等缓存,thg支持多种url模式、URL路由[RESTful],支持多项目集成、第三方扩展、支持插件。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:CmlPHP V2.7.2,快速稳定易维护的 PHP 框架
加载中

精彩评论

陨落人间
陨落人间

引用来自“回去干活”的评论

弄个强类型版本的框架出来,最低要求7.1
我就试试.
php本身就是弱类型的,非得跟java靠近,本末倒置

最新评论(6

陨落人间
陨落人间

引用来自“回去干活”的评论

弄个强类型版本的框架出来,最低要求7.1
我就试试.
php本身就是弱类型的,非得跟java靠近,本末倒置
雨空
雨空

引用来自“苏生不惑”的评论

php5.6用CURLFILE上传
5.5开始curl_file_create就可用了。5.6默认禁用@的方式
苏生不惑
苏生不惑
php5.6用CURLFILE上传
回去干活
回去干活
弄个强类型版本的框架出来,最低要求7.1
我就试试.
雨空
雨空

引用来自“陨落人间”的评论

作者只顾开发,不弄点示例出来很难推广
这个有在考虑中😄
陨落人间
陨落人间
作者只顾开发,不弄点示例出来很难推广
返回顶部
顶部