麒麟开源堡垒机 V1.31e 版本发布 - 开源中国社区
Float_left Icon_close
麒麟开源堡垒机 V1.31e 版本发布
网安1476 2016年07月18日

麒麟开源堡垒机 V1.31e 版本发布

网安1476 网安1476 发布于2016年07月18日 收藏 15

麒麟开源堡垒机 V1.31e 版本发布了,本次主要更新:

功能增加:

增加了单用户的登录、权限DEBUG功能,可以为单个用户打开或关闭DEBUG信息
2.动态口令增加了硬件令牌的认证支持(过去为手机令牌)
3.动态口令安卓APP增加了一个APP绑定多个令牌功能
4.动态口令修改为一个令牌可以绑定为多个用户使用(过去只能绑定一个用户)
5.修改了日志备份到FTP时因WINDOWS不支持文件名包括 :的问题
6.增加了配置备份到FTP服务器的功能(过去只支持SFTP)

BUG修改:

1.修改了应用发布服务器同步帐号时MYSQL超时BUG
2.修改了前台页面与后台数据库不兼容导致的dberror报警

版本说明:

麒麟堡垒机版本共计有四个字段,比如V1.31a
其中V1表示大版本,即后台的版本,所有的V1.xxx后台全是一样的,即V1.1升级到V1.2只更新前台,后台功能没有任何变化
V1.3中的3表示前台和数据库结构大版本,V1.3xx没有发生过数据库结构的变化,在v1.3xx内升级,只需要更新前台的程序不需要升级数据库的结构
v1.31最后一位1表示前台小版本,当前台有某项功能升级时,会发布
v1.31b中的字母b表示bug版本,每次修改完bug,都会将这个字母进行升级

升级说明:

V1版本之前所有的升级都不需要更新后台,只需要更新前台页面代码和数据库结构
2.在同一个前台版本中升级,不需要更新数据库结构,只需要升级页面,比如从V1.31升级到V1.32,则只要更换页面程序,不需要修改数据库结构
3.不同的前台版本升级,需要更新数据库结构和升级页面,比如从V1.21升级到V1.3,则即需要更新数据库结构,又需要升级页面
4.如果不需要新增加的功能,本版本可以一直使用等等V2版本出在进行更新,一旦使用版本出现后缀为字母的版本,说明版本出现了BUG,请查看更新说明,如果BUG在使用范围内建议进行更新

升级方法

到群内下载up.tar.gz升级包,将up.tar.gz上传到堡垒机运行如下命令:
tar xpvf up.tar.gz
bash up.sh
系统会自动比对数据结构和前台页面进行升级到最新版本

版本周期:

后台版本半年一个版本,即大版本更新为半年,每年的4月、10月更新大版本,比如今年4月出的V1.XX版本,到今年10月会出V2.XXX版本
前台大版本一般为一周到二周更新一次
前台小版本不一定,如果有使用者要求的新功能开发完成,并且使用者需要上线做发安装版本后即发布
bug版本为即时,即每次出了BUG,转天即出BUG版本


系统简介:麒麟开源堡垒机为可以与商业堡垒机媲美的低成本、高性能 、易用的堡垒机,系统支持所有的运维协议(包括 rdp/x11/vnc),内置动态口令、SSL VPN、网管监控等额外辅助模块。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:麒麟开源堡垒机 V1.31e 版本发布
分享
评论(4)
最新评论
0
加QQ群,QQ群里有发布,文档和新版本都在Q群里发布
0

引用来自“麒麟堡垒机”的评论

有啊,有一个阿里云版本的可以直接在CENTOS 7上安装
哪有阿里云版本?官网没看到呢.需要定制吗?
0
有啊,有一个阿里云版本的可以直接在CENTOS 7上安装
0
这个只能用ISO安装吗 没有办法在现有的centos上安装吗?
顶部