MongooseJS 4.5.1 发布,MongoDB 连接包 - 开源中国社区
MongooseJS 4.5.1 发布,MongoDB 连接包
oschina 2016年06月20日

MongooseJS 4.5.1 发布,MongoDB 连接包

oschina oschina 发布于2016年06月20日 收藏 13 评论 3

阿里云高性能云服务器,2折起! >>> >>>  

MongooseJS 4.5.1 发布了,Mongoose 是基于nodejs,使用javascript编程,连接mongodb数据库的软件包,使mongodb的文档数据模型变的优雅起来,方便对mongodb文档型数据库的连接和增删改查等常规数据操作。

mongoose是当前使用mean(mongodb express angularjs nodejs)全栈开发必用的连接数据库软件包。

改进日志如下:

  • fix(model): ensure wrapped insertMany() returns a promise #4237

  • fix(populate): dont overwrite populateVirtuals when populating multiple paths #4234

  • docs(model): clarify relationship between create() and save() #4233

  • fix(types): handle option param in subdoc remove() #4231 tdebarochez

  • fix(document): dedupe modified paths #4226 #4223 adambuczynski

  • fix(model): don't modify user-provided options object #4221

  • fix(document): handle setting nested path to empty object #4218 #4182

  • fix(document): clean subpaths when removing single nested #4216

  • fix(document): don't force transform on subdocs with inspect #4213

  • fix(error): allow setting .messages object #4207

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:MongooseJS 4.5.1 发布,MongoDB 连接包
分享
评论(3)
最新评论
0
请问这个只能是nodejs使用的吗?
0
不是叫mongoose吗,多了js两个字?
0
mongoose 挺好用的。

http://www.hubwiz.com/course/543b2e7788dba02718b5a4bd/
顶部