Ubuntu 16.04 LTS 推荐开源 AMDGPU 和 Radeon 驱动程序

oschina
 oschina
发布于 2016年04月04日
收藏 9

Ubuntu 16.04 LTS 将不支持 AMD 催化剂驱动作为 AMD GPU(图形处理单元)的驱动程序,相反 Canonical 建议用户采用开源的 Radeon 和 AMDGPU 作为替代。

ubuntu-16.04

Ubuntu 16.04 LTS已经放弃了 fglrx 驱动,转而推荐 Radeon 和 AMDGPU 作为替代。AMD 官方也为更好的用户体验在驱动方面投入了大量的工作,有兴趣的朋友可以阅读下 Ubuntu 16.04 LTS 发行说明的相关部分。

如果你在 2016 年 4 月 21 日正式发布之后安装 Ubuntu 16.04 LTS,一般情况下不会遇到显示驱动的问题。如果你选择从 Ubuntu 15.10 或 Ubuntu 14.04 LTS 进行升级,在升级过程中将自动从 xorg.conf 配置文件中清除 fglrx 驱动。在清除所有 AMD 催化剂驱动后,Ubuntu 16.04 LTS 会自动尝试应用 Radeon 或 AMDGPU 之一作为合适的显卡驱动。

原文地址:http://www.sysgeek.cn/canonical-recommends-amdgpu-aradeon-ubuntu-16-04/作者:sysgeek

本文转载自: http://www.linuxprobe.com/ubuntu-lts-amdgpu-radeon/

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Ubuntu 16.04 LTS 推荐开源 AMDGPU 和 Radeon 驱动程序
加载中

最新评论(5

lwd1900
lwd1900
for。
for。
装了Ubuntu16.04 感觉流畅多了
changnet
changnet
早该改了,用私有驱动的话,每升级一次内核,都要重新编译驱动。我都一直用开源驱动
eechen
eechen
Intel做的更直接,毫无保留,全部开源Intel核显驱动:
/lib/modules/`uname -r`/kernel/drivers/gpu/drm/i915/i915.ko
https://01.org/linuxgraphics/

内核内置的AMD开源驱动:
/lib/modules/`uname -r`/kernel/drivers/gpu/drm/radeon/radeon.ko

升级内核就意味着升级驱动,无需编译,1分钟安装Ubuntu官方构建的最新版Linux内核:
http://my.oschina.net/eechen/blog/202438

Nvidia的话还需要自己手动安装:
/lib/modules/`uname -r`/updates/dkms/nvidia.ko
sudo apt-get install nvidia-331 nvidia-settings nvidia-prime
http://my.oschina.net/eechen/blog/228450

Ubuntu上用i5-3230M核显就能跑Steam平台的求生之路2:
http://static.oschina.net/uploads/space/2015/1226/142142_lfW5_561214.png

Ubuntu上用i5-3230M核芯显卡在VirtualBox虚拟XP里玩3D赛车游戏LFS.
http://static.oschina.net/uploads/space/2015/1206/164803_kuot_561214.png

Ubuntu 14.04(i5-3230M集成显卡HD4000)在Firefox里跑WebGL FPS游戏BananaBread:
https://developer.mozilla.org/zh-CN/demos/detail/bananabread/download
http://static.oschina.net/uploads/space/2015/0905/142046_aVTz_561214.png
東條・スペンサー・咲
東條・スペンサー・咲
@红薯 Ubuntu 16.04 LTS 已经放弃了 fglrx 驱动,而不是驱动放弃系统。sysgeek翻译的是错的。发行日志原文是:The fglrx driver is now deprecated in 16.04。
返回顶部
顶部