Docker Hub 将放弃支持客户端 1.5 及以下版本

zigzagroad
 zigzagroad
发布于 2015年11月14日
收藏 5

Docker 再次发邮件提醒用户关于即将在 Docker Hub 放弃支持客户端 1.5 及以下版本的消息,Docker 将在下周四开始禁止这些客户端 push 到 Docker Hub,也就是 11 月 19 日。

春季的时候 Docker 发布了 Engine 1.6 版本和 Registry 2 版本,引入了一个 push/pull 协议特性更新,更快的进行镜像传输,简化镜像定义和提升安全性。Docker 社区也在积极的适应最新的特性,所以 Docker Hub 超过 99% 的使用都基于最新版本。也因此 Docker 放弃支持 Docker Hub for clients 1.5 及以下版本。

解决这些问题最简单的就是迁移,用户只需要升级 Docker 客户端到 1.6 及以上版本。请确保把你仓库所有 push 和 pull 的客户端升级到最新版本,包括开发机器,生产服务器或者是 CI 和 CD 工作流部分上的客户端版本。

* 2015 年 11 月 9 日开始,Docker 客户端 1.5 及以下版本将不再允许 push 镜像到 Docker Hub。但还是可以 pull 镜像到 Docker Hub。这些仓库可以被更新版本的 Docker 客户端访问。

* 2015 年 12 月 7 日开始,将会禁止 Docker 客户端 1.5 及以下的版本 pull 镜像到 Docker Hub,只支持 Docker 俄客户端 1.6 及以上版本。

来自 @zigzagroad 的爆料,感谢提醒:)

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Docker Hub 将放弃支持客户端 1.5 及以下版本
加载中

最新评论(6

一脸茫然
一脸茫然
sdfsadf
zigzagroad
zigzagroad

引用来自“再踏”的评论

趁docker还年轻,这种割裂还比较好处理,要是类似于python3的那种级别的割裂,现在有不少新书都还在python2.7
是的,趁早甩掉历史包袱,轻装上阵
惊鸟
惊鸟
趁docker还年轻,这种割裂还比较好处理,要是类似于python3的那种级别的割裂,现在有不少新书都还在python2.7
zigzagroad
zigzagroad

引用来自“__JM_Joy__”的评论

非常支持,打破兼容,让丑陋的hack去死吧
嗯,只有甩开历史包袱才能更好地向前发展
zigzagroad
zigzagroad
注:此文是 OSC@叶秀兰 所翻译,我只是在另一篇文章的回复中转发了原文。
__JM_Joy__
__JM_Joy__
非常支持,打破兼容,让丑陋的hack去死吧
返回顶部
顶部