Mozilla 宣布 2016 年底前停止对 NPAPI 插件支持

oschina
 oschina
发布于 2015年10月09日
收藏 2

根据最新博文,Mozilla 宣布将于 2016 年年底之前停止对网景插件应用程序接口(NPAPI)插件的支持。Mozilla 表示包括流媒体视频和剪切板访问等诸多服务都通过 NPAPI 实现,且作为原生 Web API 激活使用。为减轻系统负担提升性能,Mozilla 在博文中写道:“伴随着浏览器和网页的迅猛发展,NPAPI 已经显得老态龙钟。在此基础实现的插件存在着性能、崩溃等问题,且对于网民来说有潜在的安全隐患。”

http://static.cnbetacdn.com/article/2015/1009/b4e7d4fcbf94253.jpg

目 前谷歌的Chrome和微软的Edge浏览器已经宣布放弃对NPAPI插件的支持,所以Mozilla需要加紧步伐。不过对于那些想让Flash死亡的 Firefox用户来说可能会有点失望,Mozilla表示依然会以“通用插件策略的例外”来对待Flash for Firefox。

NPAPI Plugins in Firefox [Mozilla]

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Mozilla 宣布 2016 年底前停止对 NPAPI 插件支持
加载中

精彩评论

最新评论(15

wkl17
wkl17

引用来自“阿信sxq”的评论

我想问,不用这个了,那么用什么呢
同问..
J
Jwxl
卧槽,adblock不能用了?
gzwxn
gzwxn
NPAPI 版的 FLASH 不支持高分屏,而且也没有支持的计划。
后娘养的。
NestleCaau
NestleCaau
进步就是舍弃旧东西
tao_hunter6
tao_hunter6

引用来自“西夏一品堂”的评论

NPAPI有什么不好,为啥都不支持
主要还是安全性方面的考虑,npapi插件及其更新维护带来的安全性问题等于在浏览器上多开了一个潜在的漏洞。相比之下,现在的浏览器厂商更愿意让开发者直接使用原生html5的技术,或者象google那样的ppapi。这样制作出来的扩展程序,无论是out-of-process plugin execution,还是跨平台,都远比npapi方便和安全。不是谁学谁的问题,技术的趋势是必须紧跟的。
一个大土豆
一个大土豆

引用来自“西夏一品堂”的评论

NPAPI有什么不好,为啥都不支持
有的有点卡。
阿信sxq
阿信sxq
我想问,不用这个了,那么用什么呢
开心303
开心303
绝对正确的选择
西夏一品堂
西夏一品堂
NPAPI有什么不好,为啥都不支持
返回顶部
顶部