MyEclipse 2015 Stable 2.0 发布 - 开源中国社区
MyEclipse 2015 Stable 2.0 发布
冰雪峰 2015年06月08日

MyEclipse 2015 Stable 2.0 发布

冰雪峰 冰雪峰 发布于2015年06月08日 收藏 28 评论 25

MyEclipse 2015 Stable 2.0 重点改进了Web和Mobile功能,新增了非常强大的Minimap工具,Emmet代码编辑器,优化了JavaScript性能。

MyEclipse 2015 Stable 2.0下载地址

Luna SR 2

MyEclipse Stable 2.0基于Eclipse Luna SR2 (4.4.2)。

Minimap-快速查看源代码

当代码比较多时,Minimap可以帮助快速定位到相应的代码段。Minimap可以让程序员对整个代码有一个全局视图,从而在需要查找某段代码时可以快速定位到相应区域。



修复Tomcat Server连接器


修复了Tomcat服务器的一系列问题,自动部署和内容部署变得更加灵活易用。另外,配置文件的几个存储问题也得到了修复。

WebSphere新增连接协议


除了IPC,针对所有WAS服务器又新增了SOAP协议。还修复了工作区部署模式的几个问题。

改进JavaScript性能


MyEclipse Stable 2.0大大提升了JavaScript的分析性能,不管项目有多大,都不会影响整个MyEclipse的性能。


此外,你可以调整performance/quality设置或者给JavaScript分析设置一个范围,可以进一步优化性能。如果不想启用这些功能,也可以关掉它(Window>Preferences>MyEclipse>JavaScript>Performance)。

集成Emmet

Emmet-HTML/CSS代码快速编写神器,已加入MyEclipse 2015 Stable 2.0正式版中。

集成Tern Java 0.8.0

最新的Tern对JavaScript编码做了以下一些改进:

支持Completion Guess

使用了内容帮助之后,它会根据函数参数类型快速自动匹配,从而显示出完整参数。

支持Completion String

集成了很多短的字符串到代码中。更多请参阅https://github.com/angelozerr/tern.java/wiki/Tern-&-Completion-String-support

支持ECMAScript 6
支持RequireJS Object Literal Completion
新增支持Jasmine, Protractor, snabbit.js等框架

要使用这些新功能,打开project properties,在MyEclipse下拉菜单中选择JavaScript Resources,然后选择你想要的功能即可。

PhoneGap 4.2 CLI

使用最新的PhoneGap 4.2 CLI创建项目,首先去官网下载PhoneGap 4.2 CLI,然后在Window>Preferences下拉项中选择MyEclipse>Mobile Tools>PhoneGap Runtime即可。

改进PhoneGap插件向导性能

新版本重新调整了PhoneGap插件,从而让向导可以立即被调用,而在之前的版本中向导需要几分钟才能打开。

其他一些重要修复:

EGit更新至v3.7.0;
不再需要将EAR部署到WebSphere Portal Servers,可以单独部署Web或EJB项目;
在PhoneGap项目中,在本地创建iOS应用时,无需再让更改被识别;
HTML和JavaScript内容帮助在之前的工作区中无法在外部文件中运行;
如果使用Tomcat自动部署,你可以指定一个自定义catalina.home目录,无需保存工作区中的配置文件;
新的Maven Project向导支持Java v1.7/1.8;
Maven4MyEclipse只支持Dependencies Only Maven projects,支持Maven-specific操作;
编辑器颜色现在可以单独进行设置(Window>Preferences>General>Appearance>Editor Color Theme);
JAX-WS自底向上的Web服务生成了错误的service URL;
在某些情况下,处理Spring项目时报出大量FileNotFoundExceptions;
改进JPA项目的性能问题。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:MyEclipse 2015 Stable 2.0 发布
分享
评论(25)
最新评论
0

引用来自“阿cat”的评论

坐等秒破,,,,,,,,,,,

引用来自“风中静草”的评论

Stable 1.0已破,在用中。。2回头试试

引用来自“阿cat”的评论

嗯、我也在用、但是太多bug、2.0里很多bug被修复了!坐等大神破解131313

引用来自“风中静草”的评论

Stable 2.0已破,开始使用ing.............

引用来自“游客”的评论

如何破的,分享一下
跟1差不多。
0

引用来自“阿cat”的评论

坐等秒破,,,,,,,,,,,

引用来自“风中静草”的评论

Stable 1.0已破,在用中。。2回头试试

引用来自“阿cat”的评论

嗯、我也在用、但是太多bug、2.0里很多bug被修复了!坐等大神破解131313

引用来自“风中静草”的评论

Stable 2.0已破,开始使用ing.............
如何破的,分享一下
虽然这玩意很强大
不得不说nodepad++ 是开发利器...
0
如何破解
0

引用来自“阿cat”的评论

坐等秒破,,,,,,,,,,,

引用来自“风中静草”的评论

Stable 1.0已破,在用中。。2回头试试

引用来自“阿cat”的评论

嗯、我也在用、但是太多bug、2.0里很多bug被修复了!坐等大神破解131313

引用来自“风中静草”的评论

Stable 2.0已破,开始使用ing.............
24242424大神.......
0

引用来自“阿cat”的评论

坐等秒破,,,,,,,,,,,

引用来自“风中静草”的评论

Stable 1.0已破,在用中。。2回头试试

引用来自“阿cat”的评论

嗯、我也在用、但是太多bug、2.0里很多bug被修复了!坐等大神破解131313
Stable 2.0已破,开始使用ing.............
0
还在用8.6的路过。。。。想转idea,发现maven实在不太会用。。。
0

引用来自“阿信sxq”的评论

使用sts吧,完胜

引用来自“jokeit”的评论

敢问什么平台上?win?编辑jsp页面安好?
安好啊,完美的IDE
0

引用来自“阿信sxq”的评论

使用sts吧,完胜
敢问什么平台上?win?编辑jsp页面安好?
0
使用sts吧,完胜
0

引用来自“CodingKu”的评论

点那个下载链接 ,看了一下授权价格 ,最便宜的300多,还算能接受,但是往下瞄了一眼发现是一年的价格,然后我就有点呵呵了,想想还是用eclipse吧

引用来自“ylxs90”的评论

那个应该是一年免费升级吧?
MyEclipse按年收费(上表价格为一年单价),可一次购买多年,3年及以上还享额外优惠!买得越多,省得越多

授权有效期内特享MyEclipse厂商提供的免费技术支持和升级服务;
0

引用来自“CodingKu”的评论

点那个下载链接 ,看了一下授权价格 ,最便宜的300多,还算能接受,但是往下瞄了一眼发现是一年的价格,然后我就有点呵呵了,想想还是用eclipse吧
那个应该是一年免费升级吧?
0

引用来自“阿cat”的评论

坐等秒破,,,,,,,,,,,

引用来自“风中静草”的评论

Stable 1.0已破,在用中。。2回头试试
嗯、我也在用、但是太多bug、2.0里很多bug被修复了!坐等大神破解131313
0
太重了,很早就抛弃了
0

引用来自“阿cat”的评论

坐等秒破,,,,,,,,,,,
Stable 1.0已破,在用中。。2回头试试
0
愿意用这个的,还不如去用intellij
0
非常不喜欢
0
丑死了!
0

引用来自“窗外有个蓝蓝天”的评论

可以能访问Myeclipse的官网了,看来官方放弃封杀中国了
多少年前 就不能上了吧 = _=
0
坐等秒破,,,,,,,,,,,
顶部