Xampps 1.9.6 正式发布, PHP win环境包 - 开源中国社区
Xampps 1.9.6 正式发布, PHP win环境包
Tuesday 2015年06月08日

Xampps 1.9.6 正式发布, PHP win环境包

Tuesday Tuesday 发布于2015年06月08日 收藏 23 评论 10

更新日志:

  1. 修复部分情况下bug日志会无法显示的问题, 在每次启动过程中如果有问题, 控制面板会做到实时抓bug日志.

  2. 增加MySQL慢日志功能, 监控语句性能, 实现自我超越.

  3. 增加perl功能, 集成最新版本5.22.0, 简单试了一下, 感觉写perl也很蛋疼, 下版或者会移除.

  4. apache版本号虽然没变化, 不过opensll更新至1.0.2a, vc14编译的新apache

  5. 优化在线升级, 增加离线缓存, 过程优化.

  6. 其它细节修正.

标准版本组件如下:
   + Apache 2.4.12 (VC14)
     (IPv6 Crypto apr-1.5.1 apr-util-1.5.4 apr-iconv-1.2.1 openssl-1.0.2a zlib-1.2.8 pcre-8.37 libxml2-2.9.2 lua-5.1.5 expat-2.1.0)
   + MySQL 5.6.25 (x64 Community Server) User: root, Pass: root
   + PHP 5.6.9 (VC11 thread safe)
   + phpMyAdmin 4.4.9
   + perl 5.22.0
   + OpenSSL 1.0.2a
   + FileZilla FTP Server 0.9.52
   + tomcat 8.0.23 (The need to support JDK)
     downlink: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
   + SerAPI 1.0.1

下载地址: 约100MB
        x86: http://www.fenanr.com/ajax/jump/link_21.html
        x64: http://www.fenanr.com/ajax/jump/link_22.html
兼容版:
       x86: http://www.fenanr.com/ajax/jump/link_23.html

xampp 产品 官网首页公告表明目前已经转由他司维护, 更新速度明显放缓. 鉴于每次php, mysql升级, 都要手工调整配置很长时间. 所以决定要做二次开发版本, 此版本非作者:  Kai 'Oswald' Seidler所创, 仅仅是一位xampp多年使用及爱好者的一次升级加工. 版权所有归原作者.

分享工作室做xampp定制, 优化版本更新, 解决旧版本在各win平台运行时所产生的问题, 更新所有组件, 自动检测安装vc库等工作, 为后期维护做足准备, 目前64/32位版本已经全部上线发布, 相信此工具在windows下性能更优. 工作室凭借多年php,mysql开发经验, 为用户提供优化版xampps环境包, 用户在使用过程中遇到问题, 可以与我们Q群联系:
 
什么是xampps? 与原xampp有何区别?
  xampps 拥有中文控制面板, 更兼容的运行模式.
  xampps 组件无错误,异常日志运行, 最优化运行.
  xampps 版本更新.
  xampps 解决旧版的众多问题
  xampps 兼容win xp, 2003, win7, win8, win8.1

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Xampps 1.9.6 正式发布, PHP win环境包
分享
评论(10)
最新评论
0
Dodd
0
之前用过,很不错
0
0

引用来自“kideny”的评论

win7下面可以用php7或者php5.6.9吗?
只要不是sp1, 都是支持的..
0

引用来自“eechen”的评论

楼主可以考虑为Linux制作一个LAMP二进制集成安装包,提供一个PHP开发的Web控制面板,然后慢慢扩展到Linux系统管理,想想都有点小激动呀.

这是我的打包方法,你可以参考一下:
http://my.oschina.net/eechen/blog/298027

引用来自“Tuesday”的评论

linux用户都比较神, 喜欢自己折腾, 集成环境意义不大.
其实并不是,AMH.sh 这类的环境搭建需求还是很大的
0
win7下面可以用php7或者php5.6.9吗?
0

引用来自“eechen”的评论

楼主可以考虑为Linux制作一个LAMP二进制集成安装包,提供一个PHP开发的Web控制面板,然后慢慢扩展到Linux系统管理,想想都有点小激动呀.

这是我的打包方法,你可以参考一下:
http://my.oschina.net/eechen/blog/298027
linux用户都比较神, 喜欢自己折腾, 集成环境意义不大.
0

引用来自“绿薯”的评论

和 apache xampp 啥不同呢
这个好像没7z版本 ...不绿色吖....
安装过程中会询问你是否绿色安装..
0
和 apache xampp 啥不同呢
这个好像没7z版本 ...不绿色吖....
0
楼主可以考虑为Linux制作一个LAMP二进制集成安装包,提供一个PHP开发的Web控制面板,然后慢慢扩展到Linux系统管理,想想都有点小激动呀.

这是我的打包方法,你可以参考一下:
http://my.oschina.net/eechen/blog/298027
顶部