MyBatis 3.3.0 发布,Ognl 升级至版本 3.0.11

oschina
 oschina
发布于 2015年05月25日
收藏 21

MyBatis 3.3.0 发布,此版本主要有两个改进:

  • Ognl 升级至最新版本 3.0.11

  • 默认代理工具是 Javassist,放置在 mybatis jar 内


其他小改进和 bug 修复请看:https://github.com/mybatis/mybatis-3/issues?q=milestone%3A3.3.0 

注意,你可以继续使用 CGLIB 作为代理工具,通过添加 CGLIB 到你的 classpath,设置 MyBatis 全局参数:

<settings>
    <setting name="proxyFactory" value="CGLIB"/>
</settings>

这些都已提供在 Github 和 Maven Central。

Sincerely,
The MyBatis Team.

MyBatis 的前身就是 iBatis 。是一个数据持久层(ORM)框架。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:MyBatis 3.3.0 发布,Ognl 升级至版本 3.0.11
加载中

最新评论(20

jiangkeju
jiangkeju
是不是 mybaitas3.3.0 配合spring-mybtais1.3.0 一起升级才行?
jiangkeju
jiangkeju
我也遇到了3.2.8 升级到3,3.0. 那该怎么、解决啊。有解决的吗???
leejingyu
leejingyu

引用来自“谭耀武”的评论

3.2.8的升级到3.3.0,会有点问题,不要轻易升级

引用来自“leejingyu”的评论

真的有问题.......我也中招了

引用来自“mysilence”的评论

啥子问题啊? 求说明啊
因为那时mybatis出3.3.0 但是他的mybatis-spring沒更新,後來有出更新就都正常了.也要一起更新
m
mysilence

引用来自“谭耀武”的评论

3.2.8的升级到3.3.0,会有点问题,不要轻易升级

引用来自“leejingyu”的评论

真的有问题.......我也中招了
啥子问题啊? 求说明啊
m
mysilence

引用来自“谭耀武”的评论

3.2.8的升级到3.3.0,会有点问题,不要轻易升级
会出现什么问题? 3.3是不是不支持Spring4?
CraneH
CraneH

引用来自“茶哥强大”的评论

为什么mybatis打包体积大了一倍?
确实,是javasisit加入了原因
SmileTower
SmileTower

引用来自“谭耀武”的评论

3.2.8的升级到3.3.0,会有点问题,不要轻易升级

引用来自“leejingyu”的评论

真的有问题.......我也中招了

引用来自“厦门王五”的评论

是什么问题?
同样中招,退回来了
j
jerryscott
1. 因为打包了javasisit的实现(如果可以去掉应该可以减小体积)
2. mybatis3中缓存存在一点处理上的问题(跟hazelcast集成存在问题),这个BUG已经被修复了
3. 如果3.2.8升级到3.3存在问题可以将issue提交到mybatis github中
让mybatis比较长远稳定的支持下去是开源的应有态度
oaoit
oaoit
jar包大小翻倍
返回顶部
顶部