Mybatis 分页插件 3.7.1 发布

2015年05月06日

Mybatis分页插件 - PageHelper

如果你也在用Mybatis,建议尝试该分页插件,这一定是最方便使用的分页插件。

该插件目前支持以下数据库的物理分页:

  1. Oracle

  2. Mysql

  3. MariaDB

  4. SQLite

  5. Hsqldb

  6. PostgreSQL

  7. DB2

  8. SqlServer(2005+)

  9. Informix

3.7.1更新日志:

  • 增加Informix数据库支持,设置dialect值为informix即可

  • 解决入参为不可变Map类型时的错误

Maven坐标

<dependency>
    <groupId>com.github.pagehelper</groupId>
    <artifactId>pagehelper</artifactId>
    <version>3.7.1</version>
</dependency>

下载JAR包

分页插件pagehelper.jar:

由于使用了sql解析工具,你还需要下载jsqlparser.jar(这个文件完全独立,不依赖其他):

项目文档:如何使用分页插件

展开阅读全文
62 收藏
分享
加载中
最新评论 (13)

引用来自“颖辉小居”的评论

如果我只能用mybatis3.1 ,请问该用pagehelper的哪个版本呢?
回复@颖辉小居 : 目前的版本都不支持
2018-05-08 10:24
0
回复
举报
如果我只能用mybatis3.1 ,请问该用pagehelper的哪个版本呢?
2018-05-08 10:06
0
回复
举报

引用来自“v若水”的评论

请问一直报这个错 java.lang.NoClassDefFoundError: org/apache/ibatis/scripting/xmltags/SqlNode

引用来自“Liuzh_533”的评论

mybatis版本太低,需要用3.2.4+版本。
我还以为是我配置失误!!终于发现了。。。竟然是版本太低。。
2016-07-28 20:41
0
回复
举报

引用来自“v若水”的评论

请问一直报这个错 java.lang.NoClassDefFoundError: org/apache/ibatis/scripting/xmltags/SqlNode

引用来自“Liuzh_533”的评论

mybatis版本太低,需要用3.2.4+版本。
恩谢谢您的回答。
2015-05-11 17:15
0
回复
举报

引用来自“v若水”的评论

请问一直报这个错 java.lang.NoClassDefFoundError: org/apache/ibatis/scripting/xmltags/SqlNode

mybatis版本太低,需要用3.2.4+版本。
2015-05-11 14:23
0
回复
举报
请问一直报这个错 java.lang.NoClassDefFoundError: org/apache/ibatis/scripting/xmltags/SqlNode

2015-05-10 22:12
0
回复
举报

引用来自“swy649”的评论

版本帝。 用mybaitis自己提供的不好么。

引用来自“Liuzh_533”的评论

mybatis自带是内存分页。这个分页插件提供的是物理分页。

引用来自“pendulith”的评论

可以自己写plugin实现物理分页貌似
当然可以自己写,这个分页插件就是你说的plugin。
2015-05-08 08:34
0
回复
举报

引用来自“swy649”的评论

版本帝。 用mybaitis自己提供的不好么。

引用来自“Liuzh_533”的评论

mybatis自带是内存分页。这个分页插件提供的是物理分页。
可以自己写plugin实现物理分页貌似
2015-05-08 07:15
0
回复
举报

引用来自“swy649”的评论

版本帝。 用mybaitis自己提供的不好么。
mybatis自带是内存分页。这个分页插件提供的是物理分页。
2015-05-07 08:57
0
回复
举报
版本帝。 用mybaitis自己提供的不好么。
2015-05-06 16:22
0
回复
举报
更多评论
13 评论
62 收藏
分享
返回顶部
顶部