Debian 开发者呼吁淘汰 Python 2

oschina
 oschina
发布于 2015年04月18日
收藏 6

Python 2.7的终止支持时间为2020年,现在已经是2015年了,然而Debian中仍然有大量软件包是基于Python 2的实现。Debian的维护者开始认真讨论淘汰Python 2。开发者Paul Tagliamonte提出计划以尽快的将Python 2项目移植到Python 3,宣称“Python 2已死,Python 3万岁”。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Debian 开发者呼吁淘汰 Python 2
加载中

最新评论(62

吃土的狒狒
吃土的狒狒
PHP是世界上最好的语言,没有之一!
Fanxme
Fanxme
当年Firefox一个升级,一大片插件不兼容。更何况Python这种编程语言级别的东西?
猫大大
python不改变玩具的面貌,没有一个划时代的产品,我估计python都不温不火。就像当年google地图的推出,js的ajax模式,让js那个烂脚本语言,火到了现在。最后,再喷一下,JS 那个烂脚本,连语言都不该算。
mahengyang
mahengyang

引用来自“mahengyang”的评论

python已死,我用ruby

引用来自“blue1110”的评论

这都能看到你。。。。
谁?
As-xjc
As-xjc
无语啊, 说得好像人家不给你用python2似得, debian只是默认环境改为3, 你也可以照样继续用2, 而且2又不是不维护, 最蛋疼就是兼容,,,,,,各种为了历史问题,
军师
把最主要的库改到python3就行了,加油啊。
blue1110
blue1110

引用来自“mahengyang”的评论

python已死,我用ruby
这都能看到你。。。。
开源中国首席执行官
开源中国首席执行官
在讨论Python2与3的时候,同时把java黑了一把
c
collinsmao
没人用python3,就没有开发者去写python3的库.
没有python3的库,没人用python3
eechen
eechen
PHP7保持对PHP5大部分的兼容(包括PECL扩展),只是去掉了一些不推荐使用的函数扩展,比如mysql扩展和ereg正则表达式,因为官方交易使用mysqli和preg。Python3不兼容Python2的库,完全就是步子跨大了,结果扯到蛋。
返回顶部
顶部