CVE-2015-0240: Samba 漏洞有提权风险

oschina
 oschina
发布于 2015年02月24日
收藏 5

Samba的守护进程smbd里有一个为初始化的指针可被远程漏洞利用,这个编号CVE-2015-0240的漏洞允许一个恶意的Samba客户端发送一个特定的netlogon数据包给smbd获得smbd运行的权限,而smbd的默认权限是root,这个漏洞影响了Samba 3.5和更新的版本,主流的GNU/Linux发行版都受到了影响,目前Debian已经修复。Red Hat Security Team的漏洞的分析报告已经公布。斯拉夫兵工厂在加班的同时也建议企业和个人都打补丁,如果暂时因为开发运维水平低下而不想打补丁的也有临时降低风险的方案:在/etc/samba/smb.conf里增加:

rpc_server:netlogon=disabled

注意这个临时方案并不能在3.6.x和更早的版本上运行。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:CVE-2015-0240: Samba 漏洞有提权风险
加载中

最新评论(7

Beyonds
Beyonds
因为开发运维水平低下而不想打补丁的
alien_hjy
alien_hjy
因为开发运维水平低下3
修改性别
修改性别
为了修复这个漏洞,我特意安装了samba
气质舞王尼古拉斯赵四
气质舞王尼古拉斯赵四
为初始化,通假字
lanybass
lanybass

引用来自“eechen”的评论

http://www.ubuntu.com/usn/usn-2508-1/
sudo apt-get update && sudo apt-get install samba
重启samba服务生效.
为了修复这个漏洞,我特意安装了samba
sklinux
sklinux
a
eechen
eechen
http://www.ubuntu.com/usn/usn-2508-1/
sudo apt-get update && sudo apt-get install samba
重启samba服务生效.
返回顶部
顶部