Less.js 2.4.0 发布,CSS 预处理器

oschina
 oschina
发布于 2015年02月09日
收藏 20

Less.js 2.4.0 发布了,该版本改进内容包括:

  • 支持预处理的插件,可用于静态添加库

  • 支持空的 sourcemaps

  • Extract 和 Length 函数忽略列表中的注释

  • 碎片 URL 在 HTML 文档中的引用可被正确处理

  • 联合选择器上的扩展可更好的工作

  • 通过 !important 实现更好的嵌套 mixins

  • promise 依赖可选

  • 可正确处理使用 \r 的换行符

  • 例如 px 类大小单元的处理改进

Less CSS 是一个使用广泛的 CSS 预处理器,通过简单的语法和变量对 CSS 进行扩展,可减少很多 CSS 的代码量。

LESS 将 CSS 赋予了动态语言的特性,如 变量, 继承, 运算, 函数. LESS 既可以在 客户端 上运行 (支持IE 6+, Webkit, Firefox),也可一在服务端运行 (借助 Node.js).

在线 LESS 编译器

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Less.js 2.4.0 发布,CSS 预处理器
加载中

最新评论(3

gaubee
gaubee

引用来自“山哥”的评论

现在的less已经不再支持IE6,IE7了,好像IE8也快不支持了。
没必要支持吧,除了开发者,有谁会在浏览器上直接用LESS。现在开发工具齐全,不都是直接编译好再看效果的么。
山哥
山哥
目前只有1.7.5版本的还必须自己额外加上Array.forEach等ES5的polyfill才能在IE6+下运行。 LESS2.x 又使用了很多的ES5,ES6特性,根本就不兼容了。
山哥
山哥
现在的less已经不再支持IE6,IE7了,好像IE8也快不支持了。
返回顶部
顶部