GitLab 发布更新,修复了当前的 Git 漏洞

叶秀兰
 叶秀兰
发布于 2014年12月24日
收藏 4

GitLab 为现有的 GitLab 7.6.1 社区版本和 GitLab 7.6.2 企业版本发布了 Git (2.0.5) 二进制更新,修复了当前的 Git 漏洞

GitLab 服务端修复了包含一个恶意树的 Git 库块,所以没有利用这些来进行更新触发,GitLab.com 已经更新!

如果你当前更新了你的 Omnibus GitLab 安装到 7.6.1 CE 或者是 7.6.2 EE,那么只需要更新 Git 二进制包。

如果你的 GitLab 是手动安装升级,那么你可以在服务器更新 Git 客户端,运行以下命令: sudo git config --system receive.fsckObjects true

强烈建议所有用户更新 GitLab,特别是允许注册和含有公共项目的 GitLab 安装。

更多内容请看这里

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:GitLab 发布更新,修复了当前的 Git 漏洞
加载中

最新评论(9

Feng_Yu
Feng_Yu

引用来自“sunney888”的评论

GitLab的安装真是高难度
使用gitlab安装包安装,再无任何难度,所有依赖环境全部打包好,你需要做的仅仅是按照你的需求改一下配置文件而已
sunney888
sunney888
GitLab的安装真是高难度
壹城
壹城

引用来自“雨秋”的评论

我从7.5升到7.6之后用户无法登陆,又降回去了

引用来自“Feng_Yu”的评论

没运行db migrate吧

引用来自“雨秋”的评论

没有,运行这个就可以了吗?

引用来自“Feng_Yu”的评论

参考官方文档的升级方案,应该有迁移步骤,如果是安装包安装,执行gitlab-reconfigure应该是自动迁移数据库的,如果遇到了不起作用,那么手工执行一下就行了,参考我提的issue: https://github.com/gitlabhq/gitlabhq/issues/8143
嗯,对的,就是这个问题,谢谢啦!
Feng_Yu
Feng_Yu

引用来自“雨秋”的评论

我从7.5升到7.6之后用户无法登陆,又降回去了

引用来自“Feng_Yu”的评论

没运行db migrate吧

引用来自“雨秋”的评论

没有,运行这个就可以了吗?
参考官方文档的升级方案,应该有迁移步骤,如果是安装包安装,执行gitlab-reconfigure应该是自动迁移数据库的,如果遇到了不起作用,那么手工执行一下就行了,参考我提的issue: https://github.com/gitlabhq/gitlabhq/issues/8143
壹城
壹城

引用来自“雨秋”的评论

我从7.5升到7.6之后用户无法登陆,又降回去了

引用来自“Feng_Yu”的评论

没运行db migrate吧
没有,运行这个就可以了吗?
Feng_Yu
Feng_Yu

引用来自“雨秋”的评论

我从7.5升到7.6之后用户无法登陆,又降回去了
没运行db migrate吧
Zoker
Zoker
研究下
壹城
壹城
我从7.5升到7.6之后用户无法登陆,又降回去了
blu10ph
blu10ph
网络安全专家 @叶秀兰 ~
返回顶部
顶部