OmniFaces 2.0 发布,JSF2 工具库

2014年11月26日

OmniFaces 2.0 发布,此版本最低要求:Java 1.6, JSF 2.0, EL 2.1 and Servlet 2.5 to Java 1.7, JSF 2.2, EL 2.2, Servlet 3.0 和 CDI 1.1。其中最重要的改进是要求可选 CDI 依赖,OmniFaces 2.0 不能在没有 CDI 的环境部署。

OmniFaces 2.0 完全向后兼容 JSF 2.1,但是不再支持 JSF 2.0;向后兼容 CDI 1.0,需要在不使用 Beans#destroy() 使用方法的时候至此和 CDI 1.1。请注意,在未来的 2.x 版本可能不会再兼容 CDI 1.0 和 JSF 2.1 版本。

更多内容请看发行说明

OmniFaces 2.0 JAR

OmniFaces 是一个 JSF 2 的工具库,其目的是为了让 JSF 应用开发更加简单。

如果你厌倦了重塑JSFUtil或FacesUtil实用程序类,为每个JSF web应用程序定制组件,使用 taghandlers 等来解决JSF的缺点的话,OmniFaces可能是你要找的东西!

展开阅读全文
4 收藏
分享
加载中
最新评论 (3)
必须要求CDI,作死啊
2014-11-26 12:32
0
回复
举报
前几天刚被这货坑了一次.......
2014-11-26 09:23
0
回复
举报
Cool
2014-11-26 08:59
0
回复
举报
更多评论
3 评论
4 收藏
分享
返回顶部
顶部