GCC的插件将必须使用GPL - 开源中国社区
GCC的插件将必须使用GPL
红薯 2009年01月29日

GCC的插件将必须使用GPL

红薯 红薯 发布于2009年01月29日 收藏 0 评论 0

有免费的MySQL,为什么还要买? >>>  

当1983年Richard Stallma开始写Bison时,他是试图为预想中的GNU Operating System添瓦加砖.现在,25年之后自由软件基金会(FSF)同意GNU Compiler Collection (GCC)开发插件架构.之前,FSF和GCC项目一直争论是否要强迫插件使用GPL许可证.

1月27日GCC团队宣布了决定——插件必须使用GPL. CodeSourcery创始人、GCC指导委员会成员Mark Mitchell认为它不会对开发者造成太大的负担.

这不同于Firefox或Eclipse,它们的插件可以使用任何许可证.目前留下来的辣手问题是开发插件的框架,以使开发者更容易的向GCC项目贡献,已有一些大学开始着手.

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:GCC的插件将必须使用GPL
分享
评论(0)
最新评论
顶部