再见绿咬鹃,Ubuntu 12.10 将结束生命周期

oschina
 oschina
发布于 2014年04月16日
收藏 3

本周,我们即将迎来Ubuntu 14.04 LTS正式版,同时也不得不告别Ubuntu 12.10。开源厂商Canonical将于本周4月17日分别宣布两项事项,即上市Ubuntu 14.04 LTS正式版、结束Ubuntu 12.10生命周期。

2012年10月18日,流行Linux发行编译版Ubuntu迎来12.10,代号为“Quantal Quetzal”,其生命周期为18个月。

Ubuntu 12.10核心变化包括Linux kernel 3.5.4、GNOME 3.6、最新版Unity、LibreOffire 3.6.2、Firefox 16.01浏览器等组件。

不久前,开源厂商Canonical意识到自家的Ubuntu生命周期过长,导致开发者需要投入大量的时间维护系统升级和更新,而不是将这些时间用于研发下一个系统平台开发工作。

因此,Ubuntu 13.04只有9个月的生命周期,而开发者可以将主要精力和时间用于维护Ubuntu LTS长期生命周期支持版,例如Ubuntu 14.04 。

本周发布的Ubuntu 14.04 LTS将享有长期生命周期支持,最长可延长至2019年。

虽然官方未公布Ubuntu 12.10 EOL生命周期截止日期,但很可能截止于4月底。

稿源:IT之家www.ithome.com

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:再见绿咬鹃,Ubuntu 12.10 将结束生命周期
加载中

最新评论(49

alien_hjy
alien_hjy

引用来自“alien_hjy”的评论

滾動更新才是王道。跨版本升級故障率太高了,容易讓人懶得升級,導致版本停滯不前。生產環境中就算有LTS,也受不了每兩年大幅升級一次。

引用来自“eechen”的评论

现在的LTS版支持期都为5年,12.04 LTS支持到2017年,明天发布的14.04支持到2019年,并不是说14.04发布就不支持12.04。

就算你现在还在用12.04,你仍然可以升级到最新的内核3.14,而且只需要1分钟:
http://my.oschina.net/eechen/blog/202438
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/

引用来自“alien_hjy”的评论

五年對依賴關係和兼容性而言簡直是噩夢。到時候從12.04升級到16.04,掛掉的機率更大。LTS實際上更適用於對軟件源更新要求不高的環境,比如裝好系統和服務後幾乎不會再使用apt的情況下。

引用来自“eechen”的评论

glibc是应用和kernel的桥梁,glibc封装kernel提供的API形成系统调用system call,Ubuntu上glibc对应libc6这个包。升级kernel而不升级核心库glibc,一般不会影响软件的正常使用。我已经多次在12.04上升级到最新的Linux内核,不存在你所说的依赖和兼容性问题,反而解决了旧内核存在的问题。

引用来自“alien_hjy”的评论

嗯,又學習了。
但我之前的個人電腦存在一個問題,Ubuntu 13.10編譯安裝Linux 3.4內核,就出現了顯卡驅動工作問題。不知道是不是個例。更新版本的內核就沒出現過問題。

引用来自“eechen”的评论

你是自己编译安装,而我的方法是直接安装Ubuntu官方构建的二进制内核,而不需要自己手动配置和编译,由于是dpkg安装,新内核不会影响到旧内核,GRUB开机引导还可以选择旧内核启动。

我是用make-kpkg編譯為deb包,是可以和其它內核共存。

eechen
eechen

引用来自“alien_hjy”的评论

滾動更新才是王道。跨版本升級故障率太高了,容易讓人懶得升級,導致版本停滯不前。生產環境中就算有LTS,也受不了每兩年大幅升級一次。

引用来自“eechen”的评论

现在的LTS版支持期都为5年,12.04 LTS支持到2017年,明天发布的14.04支持到2019年,并不是说14.04发布就不支持12.04。

就算你现在还在用12.04,你仍然可以升级到最新的内核3.14,而且只需要1分钟:
http://my.oschina.net/eechen/blog/202438
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/

引用来自“alien_hjy”的评论

五年對依賴關係和兼容性而言簡直是噩夢。到時候從12.04升級到16.04,掛掉的機率更大。LTS實際上更適用於對軟件源更新要求不高的環境,比如裝好系統和服務後幾乎不會再使用apt的情況下。

引用来自“eechen”的评论

glibc是应用和kernel的桥梁,glibc封装kernel提供的API形成系统调用system call,Ubuntu上glibc对应libc6这个包。升级kernel而不升级核心库glibc,一般不会影响软件的正常使用。我已经多次在12.04上升级到最新的Linux内核,不存在你所说的依赖和兼容性问题,反而解决了旧内核存在的问题。

引用来自“alien_hjy”的评论

嗯,又學習了。
但我之前的個人電腦存在一個問題,Ubuntu 13.10編譯安裝Linux 3.4內核,就出現了顯卡驅動工作問題。不知道是不是個例。更新版本的內核就沒出現過問題。

你是自己编译安装,而我的方法是直接安装Ubuntu官方构建的二进制内核,而不需要自己手动配置和编译,由于是dpkg安装,新内核不会影响到旧内核,GRUB开机引导还可以选择旧内核启动。

alien_hjy
alien_hjy

引用来自“alien_hjy”的评论

滾動更新才是王道。跨版本升級故障率太高了,容易讓人懶得升級,導致版本停滯不前。生產環境中就算有LTS,也受不了每兩年大幅升級一次。

引用来自“eechen”的评论

现在的LTS版支持期都为5年,12.04 LTS支持到2017年,明天发布的14.04支持到2019年,并不是说14.04发布就不支持12.04。

就算你现在还在用12.04,你仍然可以升级到最新的内核3.14,而且只需要1分钟:
http://my.oschina.net/eechen/blog/202438
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/

引用来自“alien_hjy”的评论

五年對依賴關係和兼容性而言簡直是噩夢。到時候從12.04升級到16.04,掛掉的機率更大。LTS實際上更適用於對軟件源更新要求不高的環境,比如裝好系統和服務後幾乎不會再使用apt的情況下。

引用来自“eechen”的评论

glibc是应用和kernel的桥梁,glibc封装kernel提供的API形成系统调用system call,Ubuntu上glibc对应libc6这个包。升级kernel而不升级核心库glibc,一般不会影响软件的正常使用。我已经多次在12.04上升级到最新的Linux内核,不存在你所说的依赖和兼容性问题,反而解决了旧内核存在的问题。

嗯,又學習了。
但我之前的個人電腦存在一個問題,Ubuntu 13.10編譯安裝Linux 3.4內核,就出現了顯卡驅動工作問題。不知道是不是個例。更新版本的內核就沒出現過問題。

好远
好远

我刚装13.10

eechen
eechen

引用来自“alien_hjy”的评论

滾動更新才是王道。跨版本升級故障率太高了,容易讓人懶得升級,導致版本停滯不前。生產環境中就算有LTS,也受不了每兩年大幅升級一次。

引用来自“eechen”的评论

现在的LTS版支持期都为5年,12.04 LTS支持到2017年,明天发布的14.04支持到2019年,并不是说14.04发布就不支持12.04。

就算你现在还在用12.04,你仍然可以升级到最新的内核3.14,而且只需要1分钟:
http://my.oschina.net/eechen/blog/202438
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/

引用来自“alien_hjy”的评论

五年對依賴關係和兼容性而言簡直是噩夢。到時候從12.04升級到16.04,掛掉的機率更大。LTS實際上更適用於對軟件源更新要求不高的環境,比如裝好系統和服務後幾乎不會再使用apt的情況下。

glibc是应用和kernel的桥梁,glibc封装kernel提供的API形成系统调用system call,Ubuntu上glibc对应libc6这个包。升级kernel而不升级核心库glibc,一般不会影响软件的正常使用。我已经多次在12.04上升级到最新的Linux内核,不存在你所说的依赖和兼容性问题,反而解决了旧内核存在的问题。

alien_hjy
alien_hjy

引用来自“alien_hjy”的评论

滾動更新才是王道。跨版本升級故障率太高了,容易讓人懶得升級,導致版本停滯不前。生產環境中就算有LTS,也受不了每兩年大幅升級一次。

引用来自“eechen”的评论

现在的LTS版支持期都为5年,12.04 LTS支持到2017年,明天发布的14.04支持到2019年,并不是说14.04发布就不支持12.04。

就算你现在还在用12.04,你仍然可以升级到最新的内核3.14,而且只需要1分钟:
http://my.oschina.net/eechen/blog/202438
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14.1-trusty/

五年對依賴關係和兼容性而言簡直是噩夢。到時候從12.04升級到16.04,掛掉的機率更大。LTS實際上更適用於對軟件源更新要求不高的環境,比如裝好系統和服務後幾乎不會再使用apt的情況下。

中山野鬼
中山野鬼

引用来自“_bobby_”的评论

我觉着10.10版本用着挺爽的!

哈,08.04转到10.10,这是11年中的故事,已经觉得新了,很快就在纠结是否要升级到11.04,随后过了一年期盼12.10,没想到,现在已经死菜了。日子过的真快啊。

eechen
eechen

引用来自“Rhys”的评论

纳尼??我刚装上12.10!!!你们不能这样对待我!!!

引用来自“eechen”的评论

保留原有系统数据升级到最新版Ubuntu:
http://my.oschina.net/eechen/blog/222841

引用来自“温习江湖”的评论

软件的配置会有兼容性问题,建议把重要配置文件备份后全新安装(包括home目录下的配置文件)。
当然直接升级再备份删除可能有兼容性问题的软件的配置文件也没有问题。
ps:有时兼容问题是体现在效率方面的,这时比较难发现。

我发的博文其实就是重装。旧系统的所有数据都在/mybackup下面,完全不会影响新系统的正常工作。

小恶魔的面具
小恶魔的面具

果粉表示压力不大

温习江湖
温习江湖

引用来自“Rhys”的评论

纳尼??我刚装上12.10!!!你们不能这样对待我!!!

引用来自“eechen”的评论

保留原有系统数据升级到最新版Ubuntu:
http://my.oschina.net/eechen/blog/222841

软件的配置会有兼容性问题,建议把重要配置文件备份后全新安装(包括home目录下的配置文件)。
当然直接升级再备份删除可能有兼容性问题的软件的配置文件也没有问题。
ps:有时兼容问题是体现在效率方面的,这时比较难发现。

返回顶部
顶部