Activiti 5.15.1 紧急发布,重要更新版本!

oschina
 oschina
发布于 2014年03月25日
收藏 15

Activiti 5.15 刚发布没几天,就有用户反馈:在使用 MySQL 5.6+ 版本和执行升级脚本时出现 bug,示例

错误的原因是:
1) An upgrade around MySQL timestamp precision (see 'Note for MySQL users' at http://activiti.org/userguide/index.html#creatingDatabaseTable).
2)  Not having a unit test in our QA environment where we test engine upgrades on all databases. So we did have a test for it, but not with the correct type of data that causes this bug.

所以,Activiti 团队将很快发布 Activiti 5.15.1 版本来处理这个问题。

Master 已经升级到最新版本 (https://github.com/Activiti/Activiti/commit/d9eb4f1f698eb19f39c1993d7c0e9e39f342089a)

bug 修复和升级机制也已经完成 (https://github.com/Activiti/Activiti/commit/41a01f2dd44884a22ce314a1f22f6e3ccba61adc)

升级测试 (https://github.com/Activiti/Activiti-Upgrade/commit/83a39f1b45620494f0dbb7bf7ac105813cad2b5e).

5.15.1 可以从 5.7 以及以上的版本无缝升级

TL;DR: 如果你正在使用 MySQL 5.6+: 请不要升级到 5.15 ,停留在 5.14,等待 Activiti 5.15.1 升级。其他的数据库不受影响!

Activiti是一个业务流程管理(BPM)和工作流系统,适用于开发人员和系统管理员。其核心是超快速,稳定的BPMN2流程引擎。它易于与 Spring集成使用。

activiti-modeler.gif

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Activiti 5.15.1 紧急发布,重要更新版本!
加载中

最新评论(4

littleant
littleant

升级的后果就是java.lang.ClassNotFoundException: org.activiti.validation.ProcessValidator 传说maven形式下升级冒得问题 求解

唐代de豆腐
唐代de豆腐
我去
restmad
restmad
额,这。。。
返回顶部
顶部