Eclipse 官方正式支持 Java 8!

oschina
 oschina
发布于 2014年03月20日
收藏 30

来自 Eclipse JDT 的项目经理 Daniel Megert 发了封邮件宣布 Eclipse 已经正式支持 Java 8,开发者可直接下载和使用 I20140318-0830 这个版本,对于 4.3 版本的用户可参考此文

对 Java 8 的支持包括:

  • Eclipse 编译器实现新的 Java 8 语言扩展

  • 搜索和重构功能支持 Java 8

  • 快速助手和清理移植匿名类为 Lambda 表达式或者反向转换

  • 新的 Lambda 格式化器选项

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Eclipse 官方正式支持 Java 8!
加载中

最新评论(37

w
w_sabre
链接已失效
雨翔河
雨翔河

引用来自“vincent1988”的评论

12G内存,开一堆eclipse

硬盘不行照样会卡

vincent1988
vincent1988
12G内存,开一堆eclipse
本人纯属虚构
本人纯属虚构
秒开eclipse的路过

i5 750
8g ddr 1600
256GSSD
游戏级显卡
^_^
hythzx
hythzx

引用来自“lyxlgr”的评论

我就奇怪了,为什么那么多人说Eclipse卡呢,我现在同时用eclipse和IDEA,感觉Idea比Eclipse更消耗资源,idea 编译速度比eclipse慢很多,不过我还是喜欢Idea

IDEA一直都比eclipse耗资源。。。
l
lyxlgr
我就奇怪了,为什么那么多人说Eclipse卡呢,我现在同时用eclipse和IDEA,感觉Idea比Eclipse更消耗资源,idea 编译速度比eclipse慢很多,不过我还是喜欢Idea
l
lyxlgr

引用来自“先进哥”的评论

引用来自“sofn”的评论

google已经抛弃eclipse了

谷歌抛弃eclipse不是因为eclipse不好用,而是由于elipse不是由google主导,这对一个这么个公司来讲是不能容忍的

似乎IDEA也不是由Google主导吧
阿信sxq
阿信sxq
都说eclipse卡,我用了这么就得eclipse jee版本,怎么不卡啊?你们说卡的要搞清楚你们是不是用的myeclipse啊,那个加了太多的东西,当然卡了
开源中国首席大爷

引用来自“梅公子”的评论

引用来自“牛仔豆”的评论

netbeans撸过...

我再帮你撸一发

这是肿么个情况。
赵亮-碧海情天
赵亮-碧海情天

引用来自“赵亮-碧海情天”的评论

正是因为作者这么容易走神,不专注自己的工作,才导致这种BUG成了困扰。虽然他在别的场合里走神想着工作,但他在自己的工作里又走神想着什么呢? 否则的话,对于自己要处理的工作应该有足够了解,至少问题出现之后要多考虑各种可能的情况,已知的都排除,就要再补充一些遗漏的基础来作为分析的方向。而事实上,作者就是这么一个做什么事都走神的家伙。

与其工作的时候想着玩,玩的时候想着工作,不如该玩好好玩,该工作好好工作。对程序员来说,人的品性比起已知的知识更为重要。
返回顶部
顶部