pip 1.5 发布,Python 包安装和管理工具

oschina
 oschina
发布于 2014年01月03日
收藏 17

pip 1.5 发布,此版本更新内容如下:

  • BACKWARD INCOMPATIBLE pip no longer supports the --use-mirrors,-M, and --mirrors flags. The mirroring support has been removed. In order to use a mirror specify it as the primary index with -i or--index-url, or as an additional index with --extra-index-url. (Pull #1098, CVE-2013-5123)

  • BACKWARD INCOMPATIBLE pip no longer will scrape insecure external urls by default nor will it install externally hosted files by default. Users may opt into installing externally hosted or insecure files or urls using--allow-external PROJECT and --allow-unverified PROJECT. (Pull #1055)

  • BACKWARD INCOMPATIBLE pip no longer respects dependency links by default. Users may opt into respecting them again using --process-dependency-links.

  • DEPRECATION pip install --no-install and pip install--no-download are now formally deprecated.  See Issue #906 for discussion on possible alternatives, or lack thereof, in future releases.

  • DEPRECATION pip zip and pip unzip are now formally deprecated.

  • pip will now install Mac OSX platform wheels from PyPI. (Pull #1278)

  • pip now generates the appropriate platform-specific console scripts when installing wheels. (Pull #1251)

  • Pip now confirms a wheel is supported when installing directly from a path or url. (Pull #1315)

  • Fixed #1097, --ignore-installed now behaves again as designed, after it was unintentionally broke in v0.8.3 when fixing Issue #14 (Pull #1352).

  • Fixed a bug where global scripts were being removed when uninstalling –user installed packages (Pull #1353).

  • Fixed #1163, –user wasn’t being respected when installing scripts from wheels (Pull #1176).

  • Fixed #1150, we now assume ‘_’ means ‘-‘ in versions from wheel filenames (Pull #1158).

  • Fixed #219, error when using –log with a failed install (Pull #1205).

  • Fixed #1131, logging was buffered and choppy in Python 3.

  • Fixed #70,  –timeout was being ignored (Pull #1202).

  • Fixed #772, error when setting PIP_EXISTS_ACTION (Pull #1201).

  • Added colors to the logging output in order to draw attention to important warnings and errors. (Pull #1109)

  • Added warnings when using an insecure index, find-link, or dependency link. (Pull #1121)

  • Added support for installing packages from a subdirectory using the subdirectoryeditable option. ( Pull #1082 )

  • Fixed #1192. “TypeError: bad operand type for unary” in some cases when installing wheels using –find-links (Pull #1218).

  • Fixed #1133 and #317. Archive contents are now written based on system defaults and umask (i.e. permissions are not preserved), except that regular files with any execute permissions have the equivalent of “chmod +x” applied after being written (Pull #1146).

  • PreviousBuildDirError now returns a non-zero exit code and prevents the previous build dir from being cleaned in all cases (Pull #1162).

  • Renamed –allow-insecure to –allow-unverified, however the old name will continue to work for a period of time (Pull #1257).

  • Fixed #1006, error when installing local projects with symlinks in Python 3. (Pull #1311)

  • The previously hidden --log-file otion, is now shown as a general option. (Pull #1316)

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:pip 1.5 发布,Python 包安装和管理工具
加载中

最新评论(6

chenganshi
chenganshi

引用来自“PynixWang”的评论

3.4即将被集成

顶鼎
n
neoaries
PynixWang
PynixWang
3.4即将被集成
血荐轩辕
血荐轩辕
前排支持
os-sharon
os-sharon
赞!
返回顶部
顶部