ECharts 1.3.5 更新(地图大跃进,滚轮缩放,世界地图等)

Kener-林峰
 Kener-林峰
发布于 2013年12月20日
收藏 90

【ECharts 1.3.5】发布 #ECharts地图大跃进# 升级支持滚轮缩放和拖拽漫游、内置世界地图、标准GeoJson动态扩展新地图类型、子区域模式实现从内置地图中扩展出全球176个国家地区和全国600多个省市区域简图,地图新玩法~  

修改记录

[+]新增 [-]删除 [^]升级 [#]修复 【】重要

1.3.5(2013-12-19)

  • 【+】 srcipt标签式引入,兼容非模块化或基于CMD模块化(如seajs)项目引入ECharts,详见 this 》

  • 【^】 [map]支持滚轮缩放和拖拽漫游,roam:true开启

  • 【^】 [map]支持标准GeoJson动态扩展地图类型,try HK 》 USA 》

  • 【+】 [map]内置地图类型新增世界地图类型world, try this 》

  • 【^】 [map]mapType支持子区域模式,内置支持从wold、china以及中国32个省市自治区地图中扩展出176个国家地区和600多个省市区域简图, try this 》

  • [^] [map]中国地图加入南海诸岛区域

  • [^] [map]mapLocation支持百分比

  • [^] [force]tooltip完善,支持边的提示

  • [^] [force]支持了CLICK等鼠标事件,小幅度的性能优化和数据过滤后动画的改进

  • [^] [line][scatter]折线图、散点图支持symbol为image

  • [^] mobile交互优化(拖拽,点击)

  • [+] 新增专题中国经济十年时空漫游(2002-2011) 中国人口流动大潮(1987-2011)

  • [?] 依赖升级,ZRender 1.0.7+


本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:ECharts 1.3.5 更新(地图大跃进,滚轮缩放,世界地图等)
加载中

最新评论(22

zkhyt
zkhyt

引用来自“Kener-林峰”的评论

下个版本可以,开发组件的接口,你可以直接问axis要到坐标值

赞!赞!赞!! 大侠辛苦了! 期待~~
Kener-林峰
Kener-林峰
下个版本可以,开发组件的接口,你可以直接问axis要到坐标值
zkhyt
zkhyt
请问林大侠,怎么实现19楼中,替换成click事件? 需求是:“鼠标点击某个数据点时,可输出该点的横纵坐标值,不是hover也不是tip,是click”,感谢!
Kener-林峰
Kener-林峰

引用来自“davidchiu”的评论

echarts的bar类型chart支持方框选择缩放和双击事件以及右键事件吗?

试试看? http://echarts.baidu.com/doc/example/event.html
toolbox开启feature:
dataZoom:true
d
davidchiu
echarts的bar类型chart支持方框选择缩放和双击事件以及右键事件吗?
Kener-林峰
Kener-林峰
animation:false
哈哈__哈哈
哈哈__哈哈

引用来自“Kener-林峰”的评论

引用来自“邓攀”的评论

echarts不支持chrome以外的,起码在我的linux firefox opera上支持很不好,很多出不来 害的上次帮外面做的一个外包我现在只让他们用chrome访问,觉得很抱歉

linux下确实没测,据反馈,linux下关掉动画就好

怎么关闭动画?
Kener-林峰
Kener-林峰

引用来自“邓攀”的评论

echarts不支持chrome以外的,起码在我的linux firefox opera上支持很不好,很多出不来 害的上次帮外面做的一个外包我现在只让他们用chrome访问,觉得很抱歉

linux下确实没测,据反馈,linux下关掉动画就好
Kener-林峰
Kener-林峰

引用来自“谭耀武”的评论

引用来自“juqkai”的评论

有野心呀, 肯定会以这个为基础做百度地图的JSAPI

作者听说是百度的,听说而已

开源来自百度商业前端数据可视化团队 http://oss.baidu.com/
吐槽的达达仔
吐槽的达达仔

引用来自“邓攀”的评论

引用来自“吐槽的达达仔”的评论

引用来自“邓攀”的评论

echarts不支持chrome以外的,起码在我的linux firefox opera上支持很不好,很多出不来 害的上次帮外面做的一个外包我现在只让他们用chrome访问,觉得很抱歉

兼容性不好,肯定是斩立决~~

也许是我浏览器有问题你在firefox ie下试一下

。。。。IE8以上支持就可以了。。
返回顶部
顶部