IntelliJ IDEA 13 Beta 发布,支持 Java EE 7

oschina
 oschina
发布于 2013年11月08日
收藏 10

本周日,来 OSC·年终盛典收割技术干货,get新技能!!>>>

IntelliJ IDEA 13 Beta 发布了,该版本值得关注的改进有:

  • 用户界面的改进,包括新的透镜模式、搜索、展示以及提升搜索速度等等
  • 更快的 Find UsagesNavigate to 动作执行
  • Debugger 对匿名类和 Lambdas 表达式提供 Smart Step Into ,可在任何时候显示本地变量
  • 新的 Contract 注解实现更好的控制流分析
  • 改进 Find in Path 
  • 全新 Terminal 工具窗口
  • 改进对 Java 8 的支持
  • Groovy 支持增强,包括更好的类型推断、重构以及缩进
  • 支持 Java EE 7, 包括 JSF 2.2, CDI 1.1, JPA 2.1, JAX-RS 2.0, Batch Processing 等等
  • Spring 框架支持的增强,包括更容易的项目配置,更好的性能和工具
  • 新的 Android 开发工具,支持基于 Gradle 的构建系统,更好的代码完成、导航、格式化和分析,多设备预览,内建 nine-patch 编辑器,SQLite 数据库访问等等
  • 全新的更快的 Git 和 Mercurial 的日志查看器
  • 新的Web开发工具,包括更好的 JS 调试、CSS 支持增强、Emmet 预览等
  • 数据库工具 和 SQL 支持的增强,更容易的数据源配置,新的结构化视图,表编辑器和结果集查看
  • 支持 Subversion 1.8.
  • 更好的 Gradle 集成

完整的改进内容请看 official page.

此外,现在你可通过 OSChina 以全球最低的 5 折价格购买 Intellij IDEA 工具。活动详情请看这里

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:IntelliJ IDEA 13 Beta 发布,支持 Java EE 7
加载中

最新评论(38

打一把
打一把

引用来自“jorneyr”的评论

引用来自“jorneyr”的评论

有必要升级,因为IDEA 12在Mac下不支持Java 6.0

搞错了,应该是IDEA 12在Mac下不支持Java 7.0

引用来自“Sprieo”的评论

IDEA 13也不支持啊7.0啊!已装JDK7,但首次运行提示需要JDK6。还要自己改配置。改来改去麻烦,索性让它自己下了个JDK6。bingo~

引用来自“jorneyr”的评论

把IDEA 13的Info.plist里JVMVersion改成对应的Java版本就可以了,我现在使用Java 8都可以.
<key>JVMVersion</key>
<string>1.8*</string>
可是。可是。你咋不早出现……我那天改了半天,改JDM的参数啥的,不管用,我一狠心就让它自己下了个新的。
公孙二狗
公孙二狗

引用来自“jorneyr”的评论

引用来自“jorneyr”的评论

有必要升级,因为IDEA 12在Mac下不支持Java 6.0

搞错了,应该是IDEA 12在Mac下不支持Java 7.0

引用来自“Sprieo”的评论

IDEA 13也不支持啊7.0啊!已装JDK7,但首次运行提示需要JDK6。还要自己改配置。改来改去麻烦,索性让它自己下了个JDK6。bingo~
把IDEA 13的Info.plist里JVMVersion改成对应的Java版本就可以了,我现在使用Java 8都可以.
<key>JVMVersion</key>
<string>1.8*</string>
打一把
打一把

引用来自“jorneyr”的评论

引用来自“jorneyr”的评论

有必要升级,因为IDEA 12在Mac下不支持Java 6.0

搞错了,应该是IDEA 12在Mac下不支持Java 7.0
IDEA 13也不支持啊7.0啊!已装JDK7,但首次运行提示需要JDK6。还要自己改配置。改来改去麻烦,索性让它自己下了个JDK6。bingo~
Ada_Dai
Ada_Dai
还不支持NDK开发。。。
一老六一
一老六一
先试用一段时间看看
茶码古道
茶码古道

引用来自“se77en”的评论

引用来自“茶码古道”的评论

引用来自“划破的天空”的评论

我只想要占用内存小,问题少

同意!

macbook pro 16g内存表示毫无压力,君欲善其事,必先利其器!

牛逼,我的是macbook pro with retina md662,8g内存
东方星痕
东方星痕

引用来自“se77en”的评论

引用来自“茶码古道”的评论

引用来自“划破的天空”的评论

我只想要占用内存小,问题少

同意!

macbook pro 16g内存表示毫无压力,君欲善其事,必先利其器!

可是我的渣配置只有2G内存.....
陈云星
陈云星
有点贵
理工小强
理工小强

引用来自“南湖船老大”的评论

重点是支持SVN 1.8了,之前一直有问题

这个应该挺关键 百度云也对老版本的SVN支持有问题
VilenEera
VilenEera

引用来自“燃烧的火鸟”的评论

哪里下载?

http://confluence.jetbrains.com/display/IDEADEV/IDEA+13+EAP
返回顶部
顶部