Apache Subversion 1.8.4 发布

fei
 fei
发布于 2013年10月30日
收藏 5

版本控制工具Subversion 1.8.4发布. 2013-10-29 。上个版本是2013-08-29的1.8.3. 尽管GIT越来越多被使用,但相信还是有很多公司使用SVN来管理源码库。遗留产品线2013-08-29的1.7.13和2012-09-21的 1.6.19。

完全改进:

Version 1.8.4
(29 October 2013, from /branches/1.8.x)
http://svn.apache.org/repos/asf/subversion/tags/1.8.4

 User-visible changes:
  - Client- and server-side bugfixes:
    * fix assertion on urls of the form 'file://./' (r1516806)
    * stop linking against psapi.dll on Windows (r1534102)
    * translation updates for Swedish

  - Client-side bugfixes:
    * revert: fix problems reverting moves (issue #4436)
    * update: fix assertion when file external access is denied (issue #4422)
    * merge: reduce network connections for automatic merge (r1468980 et al)
    * merge: fix path corruption during reintegration (r1523666)
    * mergeinfo: fix crash (r1519955)
    * ra_serf: verify the result of xml parsing (r1501199 et al)
    * ra_serf: improve error messages during commit (r1526439)
    * ra_local: fix error with repository in Windows drive root (r1518184)
    * fix crash on windows when piped command is interrupted (r1522892)
    * fix crash in the crash handler on windows (r1532023)
    * fix assertion when upgrading old working copies (r1520529)

  - Server-side bugfixes:
    * hotcopy: cleanup unpacked revprops with '--incremental' (r1512300 et al)
    * fix OOM on concurrent requests at threaded server start (r1527103 et al)
    * fsfs: improve error message when unsupported fsfs format found (r1534158)
    * fix memory problem in 3rd party FS module loader (r1519615 et al)

 Developer-visible changes:
  - General:
    * allow compiling against serf 1.3 and later on Windows (r1517123)

  - Bindings:
    * javahl: canonicalize path for streaFileContent method (r1524869)

下载:http://apache.org/dist/subversion/subversion-1.8.4.tar.bz2

 

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Apache Subversion 1.8.4 发布
加载中

最新评论(17

mallon
mallon
支持,GIT太复杂而且大部分功能没用
netjune
netjune
还没用过就过时了
wien
wien

引用来自“bundles”的评论

用了GIT一些时间后,还是换成了SVN,不是GIT太差,只是太专业,特性完全不用到,而且很多公司并不是用来管理 代码.也有很多图片,文档之类的资源.
我只能说是专业的开源项目用GIT还是不错的.

嗯,是这样的的确
TreeNewBe
TreeNewBe

引用来自“坑主”的评论

IDE 插件跟不上, 所以我还坚守1.7

彼此彼此
ddatsh
ddatsh
svn 2.0 可以出来了
卖红薯
卖红薯
各取所需,git还是太复杂,svn有很多非技术人员也在使用。
test_song
test_song
好久没用了
乾坤摄
乾坤摄

引用来自“英年有点儿肥”的评论

引用来自“乾坤摄”的评论

引用来自“乾坤摄”的评论

支持win8.1 了没。。。。1.8.3 不支持呀

晕看错了,这个不是那个图型客户端。。。

支持,我win8.1,用的1.7的版本

1.8.1都支持 win8.1的。。。。
英年有点儿肥
英年有点儿肥

引用来自“乾坤摄”的评论

引用来自“乾坤摄”的评论

支持win8.1 了没。。。。1.8.3 不支持呀

晕看错了,这个不是那个图型客户端。。。

支持,我win8.1,用的1.7的版本
幻影浪子
幻影浪子
几年没用了..
返回顶部
顶部