jQuery 1.10 测试版发布 - 开源中国社区
jQuery 1.10 测试版发布
oschina 2013年05月11日

jQuery 1.10 测试版发布

oschina oschina 发布于2013年05月11日 收藏 8 评论 20

有免费的MySQL,为什么还要买? >>>  

jQuery官方前段时间推出了不支持IE 6/7/8的2.0版本,由于目前还有大量用户使用IE 6/7/8,因此1.x分支还要继续维护。今天jQuery官方带来了1.10的首个测试版本。

该版本包含了最初在jQuery 2.0中引入的一些小的改进,并修复了1.9.1版本中出现的bug。

除此之外,该版本还放宽了$()中HTML处理的条件,允许出现前导空格和换行符。对于来自外部源的HTML,仍然建议使用$.parseHTML()。未来jQuery版本将会对$(string)进行严格的限制,以避免跨站脚本攻击(XSS)。

由于1.10版本没有什么大的变化,对于已经升级到1.9/2.0版本的用户,可以很容易地迁移至该版本。如果还没有升级到这两个版本,可以参阅jQuery 1.9升级指南,并借助 jQuery迁移插件

详细信息:jQuery 1.10 Beta 1 Released

下载:http://code.jquery.com/jquery-1.10.0-beta1.js

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:jQuery 1.10 测试版发布
分享
评论(20)
最新评论
0

引用来自“unnamed”的评论

引用来自“XuMeijin”的评论

引用来自“unnamed”的评论

原来1.9之后还可以有1.10.。

不懂就不要乱喷,会被别人笑话的

请说一下我喷什么了?不会看人话就不要乱看,会被人笑话的

+1024!经常能看到这样的人不懂还鄙视别人的人。学来个新词儿,非要配上用场,就拿出来练口了。发出去了,结果一看,哎,用的不对!自己找了个墙角钻进去,回头他还要来解释自己没错,看吧!哈哈
0
mark
0

引用来自“欣儿”的评论

引用来自“郑纳智”的评论

引用来自“欣儿”的评论

引用来自“郑纳智”的评论

引用来自“欣儿”的评论

觉得要把ie6杜绝,还是要第三方的xp发力才可以啊

所有网站都向用户ie6/7的用户提出升级建议,我觉得这样能更快点

可以,但是从根源上入手不是更快吗?盗版的都不在默认使用IE6/7,是不是要比其他的快一些?

给人安装盗版系统的工作人员,网上的盗版windows,数不胜数,而且在这些人甚至可能不知道ie6怎么了,还不如发起web开发者之间的运动,让大家在网站中加入升级建议,鼓励用户用更好的浏览器来提升浏览体验,天朝的web开发者疲于搞兼容性,要做出好东西太难了

额,哪个说是“给人安装盗版系统的工作人员”啦,而是弄盗版系统的好不好,弄盗版系统的才是主要的吧,安装人员用的不是这些现成的吗?弄盗版系统在开始就替换老旧的IE6/7,用的不是就相应的少起来啦。网上下不到有IE6/7的系统,不就是没多重安一次,ie6/7不是就少一次吗?

历史遗留问题啊,装的人手里都是以前的盘啊什么的
0

引用来自“郑纳智”的评论

引用来自“欣儿”的评论

引用来自“郑纳智”的评论

引用来自“欣儿”的评论

觉得要把ie6杜绝,还是要第三方的xp发力才可以啊

所有网站都向用户ie6/7的用户提出升级建议,我觉得这样能更快点

可以,但是从根源上入手不是更快吗?盗版的都不在默认使用IE6/7,是不是要比其他的快一些?

给人安装盗版系统的工作人员,网上的盗版windows,数不胜数,而且在这些人甚至可能不知道ie6怎么了,还不如发起web开发者之间的运动,让大家在网站中加入升级建议,鼓励用户用更好的浏览器来提升浏览体验,天朝的web开发者疲于搞兼容性,要做出好东西太难了

额,哪个说是“给人安装盗版系统的工作人员”啦,而是弄盗版系统的好不好,弄盗版系统的才是主要的吧,安装人员用的不是这些现成的吗?弄盗版系统在开始就替换老旧的IE6/7,用的不是就相应的少起来啦。网上下不到有IE6/7的系统,不就是没多重安一次,ie6/7不是就少一次吗?
0

引用来自“欣儿”的评论

引用来自“郑纳智”的评论

引用来自“欣儿”的评论

觉得要把ie6杜绝,还是要第三方的xp发力才可以啊

所有网站都向用户ie6/7的用户提出升级建议,我觉得这样能更快点

可以,但是从根源上入手不是更快吗?盗版的都不在默认使用IE6/7,是不是要比其他的快一些?

给人安装盗版系统的工作人员,网上的盗版windows,数不胜数,而且在这些人甚至可能不知道ie6怎么了,还不如发起web开发者之间的运动,让大家在网站中加入升级建议,鼓励用户用更好的浏览器来提升浏览体验,天朝的web开发者疲于搞兼容性,要做出好东西太难了
0

引用来自“郑纳智”的评论

引用来自“欣儿”的评论

觉得要把ie6杜绝,还是要第三方的xp发力才可以啊

所有网站都向用户ie6/7的用户提出升级建议,我觉得这样能更快点

可以,但是从根源上入手不是更快吗?盗版的都不在默认使用IE6/7,是不是要比其他的快一些?
0

引用来自“郑纳智”的评论

引用来自“欣儿”的评论

觉得要把ie6杜绝,还是要第三方的xp发力才可以啊

所有网站都向用户ie6/7的用户提出升级建议,我觉得这样能更快点

只要百度、腾讯、360其中一家即可
0
如果你以为1.9之后是2.0那就错了,还有1.10
0

引用来自“欣儿”的评论

觉得要把ie6杜绝,还是要第三方的xp发力才可以啊

不要以为你周边的人用ie6,全世界都是ie6了
数据显示全球几乎所有国家ie6小于1%
唯独天曹,2位数
外国很多网站对浏览器版本有提示
没事多学习哦ls
0

引用来自“欣儿”的评论

觉得要把ie6杜绝,还是要第三方的xp发力才可以啊

所有网站都向用户ie6/7的用户提出升级建议,我觉得这样能更快点
0
觉得要把ie6杜绝,还是要第三方的xp发力才可以啊
0
学习 jquery 1.10
0

引用来自“unnamed”的评论

原来1.9之后还可以有1.10.。

1.9 -> 1.10
这是版本号,不是数学
1.9 + 0.1 = 2.0
而是1.9 -> 1.10->1.11
如果有大的变化,才2.0
0

引用来自“unnamed”的评论

原来1.9之后还可以有1.10.。

为什么不可以有
0
这个必须得,xp还那么大份额,要不都逃离了
0
敢不要这么快嘛?强迫症怎么办?
0

引用来自“XuMeijin”的评论

引用来自“unnamed”的评论

原来1.9之后还可以有1.10.。

不懂就不要乱喷,会被别人笑话的

请说一下我喷什么了?不会看人话就不要乱看,会被人笑话的
0
1.10是还兼容ie 6 7 8的
0

引用来自“unnamed”的评论

原来1.9之后还可以有1.10.。

不懂就不要乱喷,会被别人笑话的
0
原来1.9之后还可以有1.10.。
顶部