Go语言开发工具LiteIDE x18.1发布 - 开源中国社区
Go语言开发工具LiteIDE x18.1发布
七叶 2013年05月08日

Go语言开发工具LiteIDE x18.1发布

七叶 七叶 发布于2013年05月08日 收藏 29 评论 28

有免费的MySQL,为什么还要买? >>>  

LiteIDE x18.1正式发布,新版本优化Gocode输入插件,更正英语拼写错误,并修复了一些BUG

### 2013.5.8 Ver x18.1
* optimization gocode plugin
* execute preload litebuild/command/*.api
* execute enable tab key to compiler

### 2013.5.7 Ver x18
* English spelling and grammar corrections throughout, thanks for Nik-U <https://github.com/Nik-U>
* LiteIDE:
	* Improved event log
* litefind:
	* Find/Replace commands highlight existing text
	* enable find file
	* add close button	
* liteeditor:
	* Word wrap support
	* Added option to trim whitespace on save
	* Added option to hide edit toolbar
	* update kate and color scheme
	* fix kate/highlight tab
	* fix editor indent guide by tabsize
* liteapp:
	* fix full screen bug
* litebuild:
	* execute use combbox	
	* add close button
* litedebug:
	* add close button
* markdown:
	* enable markdown(sundown) extend

 

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Go语言开发工具LiteIDE x18.1发布
分享
评论(28)
最新评论
0
很不错。
0

引用来自“阿尔法兽”的评论

好用啥啊,昧着良心说话,新建工程界面拿出来和eclipse比比,实在难用

eclipse也叫好用,试试nb吧。开发起来完全不是一个效率等级的。
0

引用来自“lialun”的评论

请教各位,这是什么问题?怎么解决?
18:23:55 GolangCode: Could not find gocode (hint: is gocode installed?)

我重新编译了一下gocode就正常了!
0

引用来自“lialun”的评论

引用来自“精粹”的评论

引用来自“lialun”的评论

请教各位,这是什么问题?怎么解决?
18:23:55 GolangCode: Could not find gocode (hint: is gocode installed?)

装go语言了吗?

装了,我之前用的是liteIDE17,换到了18就出了这个问题。我现在又换回17了。go版本1.0.3

这个问题我也遇到了-_-
0
快捷键不能改吧?想去掉鼠标字号缩放功能
0

引用来自“精粹”的评论

引用来自“lialun”的评论

请教各位,这是什么问题?怎么解决?
18:23:55 GolangCode: Could not find gocode (hint: is gocode installed?)

装go语言了吗?

装了,我之前用的是liteIDE17,换到了18就出了这个问题。我现在又换回17了。go版本1.0.3
0

引用来自“Tom.Lin”的评论

引用来自“lialun”的评论

请教各位,这是什么问题?怎么解决?
18:23:55 GolangCode: Could not find gocode (hint: is gocode installed?)

把 gocode.exe 复制到 go/bin 目录里去就可以了。也可以把 %GOPATH%/bin 目录加到 PATH 里。

这个我都做了,我之前用的是liteIDE17,用着没问题也不报错,换到了18就出了这个问题
0

引用来自“lialun”的评论

请教各位,这是什么问题?怎么解决?
18:23:55 GolangCode: Could not find gocode (hint: is gocode installed?)

装go语言了吗?
0
《Go语言开发工具LiteIDE》,http://www.infoq.com/cn/articles/use-liteIDE-develop-go
0
《谷歌GO语言集成开发环境LiteIDE使用帮助》:http://wenku.baidu.com/view/2b37d5dfad51f01dc281f15d.html
0

引用来自“lialun”的评论

请教各位,这是什么问题?怎么解决?
18:23:55 GolangCode: Could not find gocode (hint: is gocode installed?)

把 gocode.exe 复制到 go/bin 目录里去就可以了。也可以把 %GOPATH%/bin 目录加到 PATH 里。
0

引用来自“TP_TP”的评论

引用来自“醪糟儿蛋”的评论

go的ide 确实不怎么样,不过liteide 算里面最好的了

试试IntelliJ IDEA + Go插件。。。

我现个都用过,IDEA的易用性好一些(特别是提示),不过不能调试
liteide易用性差一些,但是可以调试

两个都没有重构功能,我现在是两个同时用..
0

引用来自“醪糟儿蛋”的评论

go的ide 确实不怎么样,不过liteide 算里面最好的了

试试IntelliJ IDEA + Go插件。。。
0
这版本号跑的很快啊
0

引用来自“艾米”的评论

今天用了下,的确超难用。不过宁滥毋缺嘛

楼上那些说好用易用的真是昧着良心说话
0

引用来自“lialun”的评论

请教各位,这是什么问题?怎么解决?
18:23:55 GolangCode: Could not find gocode (hint: is gocode installed?)

环境变量配置的问题
0
今天用了下,的确超难用。不过宁滥毋缺嘛
0
请教各位,这是什么问题?怎么解决?
18:23:55 GolangCode: Could not find gocode (hint: is gocode installed?)
0
飞速下载了
0
好用啥啊,昧着良心说话,新建工程界面拿出来和eclipse比比,实在难用
顶部