Node.js v0.10.4 稳定版发布 - 开源中国社区
Float_left Icon_close
Node.js v0.10.4 稳定版发布
oschina 2013年04月12日

Node.js v0.10.4 稳定版发布

oschina oschina 发布于2013年04月12日 收藏 5 评论 8

阿里云高性能云服务器,2折起! >>> >>>  

Node.js 最新稳定版 0.10.4 发布了,主要改进内容包括:

  • uv: Upgrade to 0.10.4
  • npm: Upgrade to 1.2.18
  • v8: Avoid excessive memory growth in JSON.parse (Fedor Indutny)
  • child_process, cluster: fix O(n*m) scan of cmd string (Ben Noordhuis)
  • net: fix socket.bytesWritten Buffers support (Fedor Indutny)
  • buffer: fix offset checks (Łukasz Walukiewicz)
  • stream: call write cb before finish event (isaacs)
  • http: Support write(data, 'hex') (isaacs)
  • crypto: dh secret should be left-padded (Fedor Indutny)
  • process: expose NODE_MODULE_VERSION in process.versions (Rod Vagg)
  • crypto: fix constructor call in crypto streams (Andreas Madsen)
  • net: account for encoding in .byteLength (Fedor Indutny)
  • net: fix buffer iteration in bytesWritten (Fedor Indutny)
  • crypto: zero is not an error if writing 0 bytes (Fedor Indutny)
  • tls: Re-enable check of CN-ID in cert verification (Tobias Müllerleile)

相关链接:

Source Code: http://nodejs.org/dist/v0.10.4/node-v0.10.4.tar.gz

Macintosh Installer (Universal): http://nodejs.org/dist/v0.10.4/node-v0.10.4.pkg

Windows Installer: http://nodejs.org/dist/v0.10.4/node-v0.10.4-x86.msi

Windows x64 Installer: http://nodejs.org/dist/v0.10.4/x64/node-v0.10.4-x64.msi

Windows x64 Files: http://nodejs.org/dist/v0.10.4/x64/

Linux 32-bit Binary: http://nodejs.org/dist/v0.10.4/node-v0.10.4-linux-x86.tar.gz

Linux 64-bit Binary: http://nodejs.org/dist/v0.10.4/node-v0.10.4-linux-x64.tar.gz

Solaris 32-bit Binary: http://nodejs.org/dist/v0.10.4/node-v0.10.4-sunos-x86.tar.gz

Solaris 64-bit Binary: http://nodejs.org/dist/v0.10.4/node-v0.10.4-sunos-x64.tar.gz

Other release files: http://nodejs.org/dist/v0.10.4/

Website: http://nodejs.org/docs/v0.10.4/

Documentation: http://nodejs.org/docs/v0.10.4/api/

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Node.js v0.10.4 稳定版发布
分享
评论(8)
最新评论
0
直接编译安装,替换原来的bin文件,然后重启服务就行了。不过新版本的nodejs对glibc的要求比较高,glibc是linux的核心文件,升级失败可能导致系统不能启动,我就失败过。
0

引用来自“gm100861”的评论

要求的glibc太高了,这个东西还不太好升,有没有考虑过linux用户的感受啊。

怎么升级node.js ?
0
要求的glibc太高了,这个东西还不太好升,有没有考虑过linux用户的感受啊。
0
等1.2.x 估计比较稳定.
0
期待1.0
0
准备伸到0.100
0
而且每个版本都是稳定版本,不知道真的假的,不敢在项目中实践啊!
0
更新好快
顶部