jQuery 1.9 beta1 发布,删除被废弃的 API

oschina
 oschina
发布于 2012年12月18日
收藏 4

jQuery 1.9 发布了首个 Beta 版本,该版本删除了之前版本已经宣布废弃的 API。因此引入了 jQuery Migrate 插件,该插件可以在无需修改代码的情况下解决现有代码中使用了被废弃和被删除的方法。详情请看  plugin documentation

此外,jQuery 1.9 Beta1 还包含如下改进:

  • 在.pushStack()中移除了.selector的部分计算功能
  • 将不建议使用的功能移到兼容性插件中
  • jQuery.later
  • 将selector解释为HTML
  • 移除了jQuery.sub
  • 更改代理服务器,允许参数局部套用,而不会覆盖上下文
  • 在$.fn.serialzeArray中实现HTML5形式的数据结构
  • 公共API方法不应该有私有参数
  • 在jQuery.attr和jQuery.access中移除pass参数

此外该版本还修复了很多 bug,详细列表请看这里

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:jQuery 1.9 beta1 发布,删除被废弃的 API
加载中

最新评论(6

傅小黑
傅小黑

引用来自“屈超”的评论

引用来自“傅小黑”的评论

赶紧模块化,文件太大啦

head.js 是你需要的

我说的是CMD或者AMD的模块化,类似seajs模块,把jquery拆分
屈超
屈超

引用来自“傅小黑”的评论

赶紧模块化,文件太大啦

head.js 是你需要的
冰力
冰力

引用来自“傅小黑”的评论

赶紧模块化,文件太大啦

Mootools
傅小黑
傅小黑
赶紧模块化,文件太大啦
任再旺
任再旺
更新的真快啊
返回顶部
顶部