Apache HTTP Server 源代码泄露漏洞

来源: 投稿
2024-07-05 09:23:00

漏洞描述

Apache HTTP Server 是美国阿帕奇(Apache)基金会的一款开源网页服务器,ap_set_content_type 函数用于设置请求的content-type。

Apache HTTP Server 的 2.4.60 版本中 ap_set_content_type 函数未正确校验content-type的来源,在某些间接请求文件的情况下,AddType及类似配置会导致本地脚本文件的内容泄露,攻击者可能利用该漏洞获取php等脚本语言源代码。

修复版本通过替换函数 ap_set_content_type 为 ap_set_content_type_ex,并增加额外的参数,确保content-type被正确地识别和处理,从而避免PHP脚本等内容未经解析直接输出。

漏洞名称 Apache HTTP Server 源代码泄露漏洞
漏洞类型 未授权敏感信息泄露
发现时间 2024-07-04
漏洞影响广度 -
MPS编号 MPS-9gev-d08l
CVE编号 CVE-2024-39884
CNVD编号 -

影响范围

http_server@[2.4.60, 2.4.61)

apache2@(-∞, 2.4.61-1)

修复方案

将组件 http_server 升级至 2.4.61 及以上版本

将组件 apache2 升级至 2.4.61-1 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-9gev-d08l

Commit

证明影响版本

https://nvd.nist.gov/vuln/detail/CVE-2024-39884

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部