Ghostscript 格式化字符串漏洞

来源: 投稿
2024-07-04 18:19:00

漏洞描述

Artifex Software Ghostscript 是美国 Artifex Software 公司的一款开源的 PostScript 解析器,UniPrint 是 Ghostscript 中的通用打印机设备。

在受影响版本中,upWriteComponentCommands 和 upYMoveCommand 参数作为设备选项,原本预期只接受单个格式说明符的格式化字符串,但实际上却能够接受任意含有多个格式说明符的字符串。攻击者可以通过构造特定的格式化字符串来泄露堆栈数据或进行内存破坏,进而可以绕过 -dSAFER 沙盒限制,导致远程代码执行。

修复版本中通过添加 --permit-devices= 选项来限制更改相关设备。

漏洞名称 Ghostscript 格式化字符串漏洞
漏洞类型 输入验证不恰当
发现时间 2024-07-03
漏洞影响广度 -
MPS编号 MPS-yu7m-no5w
CVE编号 CVE-2024-29510
CNVD编号 -

影响范围

ghostscript@(-∞, 10.03.1)

ghostscript@影响所有版本

ghostscript-doc@影响所有版本

ghostscript-tools-fonts@影响所有版本

ghostscript-tools-dvipdf@影响所有版本

ghostscript-tools-printing@影响所有版本

ghostscript-x11@影响所有版本

libgs@影响所有版本

libgs-devel@影响所有版本

ghostscript@影响所有版本

ghostscript-doc@影响所有版本

ghostscript-tools-dvipdf@影响所有版本

ghostscript-tools-fonts@影响所有版本

gimp:flatpak/ghostscript-doc@影响所有版本

gimp:flatpak/ghostscript-tools-fonts@影响所有版本

gimp:flatpak/ghostscript-x11@影响所有版本

gimp:flatpak/libgs-devel@影响所有版本

libgs@影响所有版本

libgs-devel@影响所有版本

ghostscript-doc@影响所有版本

ghostscript-x11@影响所有版本

libgs-devel@影响所有版本

ghostscript@影响所有版本

ghostscript-tools-fonts@影响所有版本

gimp:flatpak/ghostscript@影响所有版本

gimp:flatpak/ghostscript-x11@影响所有版本

gimp:flatpak/libgs-devel@影响所有版本

ghostscript-tools-printing@影响所有版本

ghostscript-x11@影响所有版本

gimp:flatpak/ghostscript@影响所有版本

gimp:flatpak/ghostscript-tools-dvipdf@影响所有版本

gimp:flatpak/ghostscript-tools-printing@影响所有版本

gimp:flatpak/libgs@影响所有版本

ghostscript@影响所有版本

ghostscript-tools-dvipdf@影响所有版本

ghostscript-tools-fonts@影响所有版本

ghostscript-tools-printing@影响所有版本

libgs@影响所有版本

ghostscript-doc@影响所有版本

ghostscript-tools-dvipdf@影响所有版本

ghostscript-tools-printing@影响所有版本

ghostscript-x11@影响所有版本

gimp:flatpak/ghostscript-doc@影响所有版本

gimp:flatpak/ghostscript-tools-dvipdf@影响所有版本

gimp:flatpak/ghostscript-tools-fonts@影响所有版本

gimp:flatpak/ghostscript-tools-printing@影响所有版本

gimp:flatpak/libgs@影响所有版本

libgs@影响所有版本

libgs-devel@影响所有版本

ghostscript@(-∞, 10.03.1~dfsg~git20240518-1)

ghostscript@影响所有版本

修复方案

将组件 ghostscript 升级至 10.03.1~dfsg~git20240518-1 及以上版本

将组件 ghostscript 升级至 10.03.1 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-yu7m-no5w

Commit

 

 

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部