OpenSSH Server远程代码执行漏洞

来源: 投稿
2024-07-02 00:49:00

漏洞描述

OpenSSH 是使用 SSH 协议进行远程登录的连接工具,OpenSSH 服务器端(sshd)在2020年10月的变更中错误修改了代码,导致CVE-2006-5051中的条件竞争漏洞再次出现。

当客户端在 LoginGraceTime 秒数内未认证成功,sshd 的 SIGALRM 处理程序会异步调用一些非异步信号安全的函数(如syslog()),可能导致远程代码执行。

针对32位操作系统可能通过长时间尝试连接触发该漏洞,在64位系统中则难以触发。

漏洞影响 8.5p1 到 9.7p1 版本的OpenSSH,但不影响使用syslog_r()的OpenBSD版本,修复版本通过中移除了sshsigdie 函数来避免受到漏洞影响。

漏洞名称 OpenSSH Server远程代码执行漏洞
漏洞类型 双重释放
发现时间 2024-07-01
漏洞影响广度 -
MPS编号 MPS-8p7l-b5rh
CVE编号 CVE-2024-6387
CNVD编号 -

影响范围

openssh@[8.5p1, 9.8p1)

修复方案

将组件 openssh 升级至 9.8p1 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-8p7l-b5rh

证明影响版本

Commit

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击加入讨论🔥(1) 发布并加入讨论🔥
1 评论
0 收藏
分享
返回顶部
顶部