PHP CGI Windows下远程代码执行漏洞

来源: 投稿
2024-06-07 18:24:00

漏洞描述

PHP是一种在服务器端执行的脚本语言。

在 PHP 的 8.3.8 版本之前存在命令执行漏洞,由于 Windows 的 "Best-Fit Mapping" 特性,在处理查询字符串时,非 ASCII 字符可能被错误地映射为破折号(-),导致命令行参数解析错误。

当 php_cgi 运行在 Windows 平台上,且代码页为繁体中文、简体中文或日文时,攻击者可以通过特定的查询字符串注入恶意参数,从而执行任意代码。

漏洞名称 PHP CGI Windows下远程代码执行漏洞
漏洞类型 输入验证不恰当
发现时间 2024-06-07
漏洞影响广度 -
MPS编号 MPS-wk9q-5g71
CVE编号 CVE-2024-4577
CNVD编号 -

影响范围

php@[8.3, 8.3.8)

php@[8.2, 8.2.20)

php@(-∞, 8.1.29)

修复方案

将组件 php 升级至 8.3.8 及以上版本

将组件 php 升级至 8.2.20 及以上版本

将组件 php 升级至 8.1.29 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-wk9q-5g71

Commit

https://nvd.nist.gov/vuln/detail/CVE-2024-4577

https://devco.re/blog/2024/06/06/security-alert-cve-2024-4577-php-cgi-argument-injection-vulnerability-en/

changelog

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部