jQuery UI 1.14.0-beta.1 发布

来源: OSCHINA
2024-05-16 13:55:40

jQuery UI 1.14.0 的第一个测试版现已发布。这个版本没有提供任何新功能,只有以下的破坏性改动:

  • 仅官方支持最新版本的 Chrome、Firefox、Safari 和 Edge;不支持任何版本的 IE 和 Edge Legacy。与过去版本中所做的相反,支持不受支持的浏览器的代码已被删除。
  • 仅支持 jQuery Core 每个主要版本中的最新 jQuery 版本。此 Beta 版针对 jQuery 1.12.4、2.2.4 和 3.7.1 以及两个开发版本进行了测试:3.x 和 4.x。
  • 默认情况下禁用与 1.11 API 的向下兼容性。要重新启用它(恢复默认的 1.13 行为),需要将 jQuery.uiBackCompat flag 设置为 true。

该测试版未集成到 jQuery UI Download Builder 中;将在最终版本发布前添加对 jQuery UI 1.14 的支持。因此,该测试版不提供压缩包。

值得注意的是,从2024年6月开始,Download Builder 将只支持 jQuery UI 1.12 或更新版本。更多信息可阅读 Plans for jQuery UI 1.14 博文。

jQuery UI 目前处于维护状态。官方表示将确保该库与新发布的 jQuery 兼容,并修复安全问题,但不计划开发新的重要功能。同时也会尝试修复 jQuery UI 1.12.1 中的一些重要回归,但长期存在的老 bug 可能不会得到修复。但不会影响仍在积极维护中 jQuery Core。

 更多详情可查看官方公告

展开阅读全文
点击加入讨论🔥(2) 发布并加入讨论🔥
2 评论
1 收藏
分享
返回顶部
顶部