cacti <= 1.2.26 远程代码执行漏洞

来源: 投稿
2024-05-15 23:41:00

漏洞描述

Cacti 是一款基于 PHP 开发的网络流量监测图形分析工具。

在受影响的版本中,由于 /lib/import.php 文件中的 import_package 函数未对用户可控的模板文件进行过滤,具有“导入模板”权限的攻击者可以利用 Package Import 功能在目标系统上写入或覆盖 Web 服务器上的任意文件,从而导致执行任意 PHP 代码。

漏洞名称 cacti <= 1.2.26 远程代码执行漏洞
漏洞类型 代码注入
发现时间 2024-05-14
漏洞影响广度 -
MPS编号 MPS-580w-3ubq
CVE编号 CVE-2024-25641
CNVD编号 -

影响范围

cacti@(-∞, 1.2.27)

修复方案

将组件 cacti 升级至 1.2.27 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-580w-3ubq

https://nvd.nist.gov/vuln/detail/CVE-2024-25641

https://github.com/Cacti/cacti/security/advisories/GHSA-7cmj-g5qc-pj88

https://github.com/Cacti/cacti/commit/79b1b8b62f3008e3a49f26bd6a1a049734eac6d3

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部