FFmpeg < n7.0 堆溢出漏洞

来源: 投稿
2024-04-29 11:27:00

漏洞描述

FFmpeg 是开源的多媒体框架,支持音频和视频的录制、转换以及流处理,stereowiden filter是其中的音频过滤器,用于增强立体声音轨的空间感。

受影响版本中,由于 libavfilter/af_stereowiden.c 实现中未对 StereoWidenContext 指针变量长度为0的情况进行校验导致出现堆溢出漏洞,当使用 stereowiden filter 处理攻击者可控的音频文件时可能导致程序崩溃或远程代码执行。

漏洞名称 FFmpeg < n7.0 堆溢出漏洞
漏洞类型 堆缓冲区溢出
发现时间 2024-04-28
漏洞影响广度 一般
MPS编号 MPS-akej-cx6f
CVE编号 CVE-2023-51794
CNVD编号 -

影响范围

ffmpeg@(-∞, n7.0)

ffmpeg@影响所有版本

ffmpeg@影响所有版本

ffmpeg@影响所有版本

修复方案

将组件 ffmpeg 升级至 n7.0 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-akej-cx6f

https://nvd.nist.gov/vuln/detail/CVE-2023-51794

https://trac.ffmpeg.org/ticket/10746

https://github.com/FFmpeg/FFmpeg/commit/50f0f8c53c818f73fe2d752708e2fa9d2a2d8a07

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
1 收藏
分享
返回顶部
顶部