Nim 2.0.4 & 1.6.20 LTS 发布

来源: 投稿
2024-04-17 12:07:35

2024年4月16日,Nim 为两个分支发布了新版本:2.0.4 和 1.6.20 LTS。

2.0.4包含了与四个月前发布的Nim 2.0.2相比的23项提交,带来了错误修复和改进。

对于那些尚未切换到Nim v2.0的用户,Nim团队发布了Nim 1.6.x的第九个补丁版本。这是一个小版本,包含了13项提交

Nim 2.0.4 主要变化

  • 修复了“从mymodule导入sth编译时出错,试图查看模块sthfrommymodule”的问题(#23148

  • 修复了“对内联toOpenArray长度操作返回错误结果”的问题(#23280

  • 修复了“Nimsuggest在给表赋值无效时出现段错误”的问题(#22753

完整的更改列表可在此处找到。

Nim 1.6.20 LTS 主要变化

  • 修复了 "从 mymodule 导入 sth 时编译并试图查看 sthfrommymodule 模块" (#23148)
  • 修复了 "对内联 toOpenArray len 的操作返回错误结果" (#23280)
  • 修复了"[Backport 2.0] Itanium 处理方案" (#23301)
  • 修复了 "Nimsuggest 在对表进行无效赋值时发生故障" (#22753)

完整的更改列表可在此处找到。

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部