Apache Pulsar 主题级策略管理模块存在越权漏洞

来源: 投稿
2024-03-14 10:13:00

漏洞描述

Apache Pulsar 是开源的分布式发布-订阅消息传递系统,主题级策略管理模块允许高权限用户(如租户管理员或超级用户角色)对主题应用特定的配置和策略。

受影响版本中存在身份验证不当漏洞,导致具有生产或消费权限的用户可通过Pulsar管理工具pulsar-admin、REST API或者Java代码修改主题级策略(例如消息保留策略、TTL 和卸载设置),进而窃取服务端敏感信息或导致服务中断。

漏洞名称 Apache Pulsar 主题级策略管理模块存在越权漏洞
漏洞类型 授权检查错误
发现时间 2024-03-13
漏洞影响广度 一般
MPS编号 MPS-2zt9-up36
CVE编号 CVE-2024-28098
CNVD编号 -

影响范围

org.apache.pulsar:pulsar-broker@[2.11.0, 2.11.4)

org.apache.pulsar:pulsar-broker@[3.1.0, 3.1.3)

pulsar@[2.10.0, 2.10.6)

pulsar@[2.11.0, 2.11.4)

pulsar@[3.0.0, 3.0.3)

pulsar@[3.1.0, 3.1.3)

pulsar@[3.2.0, 3.2.1)

org.apache.pulsar:pulsar-broker@[2.10.0, 2.10.6)

org.apache.pulsar:pulsar-broker@[3.0.0, 3.0.3)

org.apache.pulsar:pulsar-broker@[3.2.0, 3.2.1)

修复方案

将组件 pulsar 升级至 3.1.3 及以上版本

将组件 pulsar 升级至 3.2.1 及以上版本

将 org.apache.pulsar:pulsar-broker 升级至 3.2.1 及以上版本

将 org.apache.pulsar:pulsar-broker 升级至 2.11.4 及以上版本

将 org.apache.pulsar:pulsar-broker 升级至 3.1.3 及以上版本

将组件 pulsar 升级至 2.10.6 及以上版本

将 org.apache.pulsar:pulsar-broker 升级至 3.0.3 及以上版本

将组件 pulsar 升级至 2.11.4 及以上版本

将组件 pulsar 升级至 3.0.3 及以上版本

将 org.apache.pulsar:pulsar-broker 升级至 2.10.6 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-2zt9-up36

https://nvd.nist.gov/vuln/detail/CVE-2024-28098

https://pulsar.apache.org/security/CVE-2024-28098/

https://github.com/apache/pulsar/commit/5198554230a098246b8d78ef77ccf898aa54f86d

https://pulsar.apache.org/docs/next/admin-api-topics/

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部