VersionFox 0.2.4 发布:一个工具管理所有运行时版本!

来源: 投稿
作者: VersionFox
2024-03-05 10:24:00

项目地址: https://github.com/version-fox/vfox

官网地址: https://vfox.lhan.me/zh-hans/

此版本的主要变化是修复了 PATH 环境变量中的重复值问题,并对用户体验进行了一些改进。我们还添加了一个文档网站:https://vfox.lhan.me

更新内容:

新增插件:

新贡献者:

Full Changelog: v0.2.3...v0.2.4

 

已支持插件:

Name Version Author Description
dart/dart 0.0.1 Aooohan dart plugin, support for getting stable, dev, beta version
deno/deno 0.0.1 Aooohan Deno plugin, https://deno.com/
dotnet/dotnet 0.0.1 Korbinian Habereder dotnet plugin, support for dotnet sdks 6.0, 7.0, 8.0
flutter/flutter-cn 0.0.1 Aooohan flutter plugin for China, support for getting stable, dev, beta version
flutter/flutter 0.0.2 Aooohan flutter plugin, support for getting stable, dev, beta version
golang/golang 0.0.2 Aooohan  
gradle/gradle 0.0.1 ahai gradle
java/adoptium-jdk 0.0.1 aooohan Adoptium JDK
java/azul-jdk 0.0.1 yimiaoxiehou Azul JDK, also known as Zulu
java/graalvm 0.0.1 ahai graalvm JDK
kotlin/kotlin 0.0.1 Aooohan Kotlin plugin
maven/maven 0.0.1 Aooohan  
nodejs/nodejs 0.0.4 Aooohan Node.js
nodejs/npmmirror 0.0.2 yimiaoxiehou install Node.js use https://cdn.npmmirror.com
python/npmmirror 0.0.3 aooohan vfox >= 0.2.3 !!! From npmmirror.org. For Windows, only support >=3.5.0, but no restrictions for unix-like
python/python 0.0.3 aooohan vfox >= 0.2.3 !! For Windows, only support >=3.5.0, but no restrictions for unix-like
zig/zig 0.0.4 aooohan Zig
 
 

快速开始

亮点:

  • 跨平台 (Windows、Linux、macOS), 不同的平台拥有相同的用户体验
  • 使用一致的命令管理所有语言
  • 简单的插件系统添加对您所需 SDK 的支持
  • 支持 Global、Project、Session 三种作用域
  • 切换项目时,自动切换到对应版本

 

详细的安装指南请参见 快速入门

1.选择一个适合你的安装方式

2. ⚠️ 挂载vfox到你的 Shell (从下面选择一条适合你 shell 的命令) ⚠️

echo 'eval "$(vfox activate bash)"' >> ~/.bashrc
echo 'eval "$(vfox activate zsh)"' >> ~/.zshrc
echo 'vfox activate fish | source' >> ~/.config/fish/config.fish

# PowerShell:
# 1. 打开 PowerShell 配置文件:
New-Item -Type File -Path $PROFILE # 无需在意 `文件已存在` 错误
Invoke-Item $PROFILE
# 2. 将下面一行添加到你的 $PROFILE 文件末尾并保存:
Invoke-Expression "$(vfox activate pwsh)"

请记住重启你的 Shell 以应用更改。

3. 添加插件

$ vfox add nodejs/nodejs

4. 安装版本

vfox install nodejs@latest

5. 切换版本

$ vfox use nodejs@21.5.0
$ node -v
21.5.0

目前已支持多种开发语言,欢迎使用~~

作用域演示

Project 作用域

Session 作用域

Node 完整演示

项目地址: https://github.com/version-fox/vfox

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
5 收藏
分享
返回顶部
顶部