Dataease jdbc 反序列化漏洞

来源: 投稿
2024-03-01 14:06:00

漏洞描述

Dataease是一款开源的数据可视化分析工具。

受影响版本中,由于未对用户输入的数据库连接参数做有效过滤,具有 Dataease 登陆权限的攻击者可通过使用URL编码 jdbc url 中的 autoDeserialize、allowUrlInLocalInfile参数绕过 jdbcUrl 检测,进而读取 MySQL 客户端任意文件或反序列化恶意代码。

漏洞名称 Dataease jdbc 反序列化漏洞
漏洞类型 反序列化
发现时间 2024-02-29
漏洞影响广度 一般
MPS编号 MPS-j54s-zgbo
CVE编号 CVE-2024-23328
CNVD编号 -

影响范围

dataease@(-∞, 1.18.15)

io.dataease:core-backend@(-∞, 1.18.15)

修复方案

将组件 dataease 升级至 1.18.15 及以上版本

将 io.dataease:core-backend 升级至 1.18.15 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-j54s-zgbo

https://nvd.nist.gov/vuln/detail/CVE-2024-23328

 

 

 

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部