Node.js 存在权限提升漏洞

来源: 投稿
2024-02-22 10:14:00

漏洞描述

Node.js 是开源、跨平台的 JavaScript 运行时环境,CAP_NET_BIND_SERVICE 是Linux操作系统中的一种特殊能力(capabilities),它允许非特权进程绑定到系统的特权端口上。

受影响版本中,由于 node::credentials 模块对 CAP_NET_BIND_SERVICE 安全机制处理存在缺陷,导致系统低权限的攻击者可通过修改 CAP_NET_BIND_SERVICE 将 Node 应用绑定至特权端口,并将恶意代码注入到Node应用中,通过修改 NODE_OPTIONS 环境变量,进而以应用当前的用户权限在主机上执行恶意代码。

漏洞名称 Node.js 存在权限提升漏洞
漏洞类型 权限管理不当
发现时间 2024-02-21
漏洞影响广度 广
MPS编号 MPS-lvsi-p1yd
CVE编号 CVE-2024-21892
CNVD编号 -

影响范围

node.js@[20.11.0, 20.11.1)

node.js@[18.19.0, 18.19.1)

node.js@[21.6.0, 21.6.2)

修复方案

将组件 node.js 升级至 20.11.1 及以上版本

将组件 node.js 升级至 18.19.1 及以上版本

将组件 node.js 升级至 21.6.2 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-lvsi-p1yd

https://nvd.nist.gov/vuln/detail/CVE-2024-21892

https://hackerone.com/reports/2237545

https://github.com/nodejs/node/commit/10ecf400679e04eddab940721cad3f6c1d603b61

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
1 收藏
分享
返回顶部
顶部