Apache Camel JDBCAggregationRepository反序列化漏洞

来源: 投稿
2024-02-20 18:26:00

漏洞描述

Apache Camel 是开源的系统间数据交互集成框架。

在受影响版本中,由于对JDBCAggregationRepository中exchange的实现存在未限制的反序列化逻辑,当攻击者可控制数据库中exchange字段值时,可以反序列化任意类,造成任意代码执行。

在修复版本中,通过校验逻辑限制其仅允许反序列化java及camel自身类。

漏洞名称 Apache Camel JDBCAggregationRepository反序列化漏洞
漏洞类型 反序列化
发现时间 2024-02-20
漏洞影响广度
MPS编号 MPS-03tm-wyhp
CVE编号 CVE-2024-22369
CNVD编号 -

影响范围

org.apache.camel:camel-sql@[3.0.0, 3.21.4)

org.apache.camel:camel-sql@[3.22.0, 3.22.1)

org.apache.camel:camel-sql@[4.0.0, 4.0.4)

org.apache.camel:camel-sql@[4.1.0, 4.4.0)

修复方案

升级org.apache.camel:camel-sql到3.21.4、3.22.1、4.0.4、4.4.0或更高版本

参考链接

https://www.oscs1024.com/hd/MPS-03tm-wyhp

Issue

CVE

官方公告

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部