Helm < 3.14.1 路径遍历漏洞

来源: 投稿
2024-02-16 10:03:00

漏洞描述

Helm 是一个用于管理 Charts 的工具。Charts 是预配置的 Kubernetes 资源的包。

Helm 客户端或 SDK 在保存 Chart 目录时未验证目录路径的合法性。攻击者可以将 Chart.yaml 文件中的 Chart 名称改为相对路径,Chart 将根据相对路径保存在其预期目录之外。

漏洞名称 Helm < 3.14.1 路径遍历漏洞
漏洞类型 路径遍历
发现时间 2024-02-15
漏洞影响广度 广
MPS编号 MPS-2si9-mtja
CVE编号 CVE-2024-25620
CNVD编号 -

影响范围

helm.sh/helm/v3 @(-∞, 3.14.1)

修复方案

将 github.com/helm/helm 升级至 3.14.1 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-2si9-mtja

https://nvd.nist.gov/vuln/detail/CVE-2024-25620

 

Commit

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部