Apache bRPC 存在 http 请求走私风险

来源: 投稿
2024-02-09 10:46:00

漏洞描述

Apache bRPC 是百度开源的工业级 RPC 框架,常用于搜索、存储、机器学习等高性能系统。

Apache bRPC 0.9.5至1.7.0版本中由于使用 http_parser 库不符合RFC-7230 HTTP 1.1 规范,当 bRPC 后端的 http 服务器通过持久话连接接收特定前端服务器的请求(需要前端服务器使用 TE 解析http请求),攻击者可发送包含恶意 Transfer-Encoding 和 Content-Length 标头的 http 请求进行请求走私,从而窃取用户凭据等敏感信息。

漏洞名称 Apache bRPC 存在http请求走私风险
漏洞类型 HTTP请求走私
发现时间 2024-02-08
漏洞影响广度 一般
MPS编号 MPS-2glc-5ao0
CVE编号 CVE-2024-23452
CNVD编号 -

影响范围

brpc@[0.9.5, 1.8.0)

修复方案

升级brpc到 1.8.0 或更高版本

参考链接

https://www.oscs1024.com/hd/MPS-2glc-5ao0

https://nvd.nist.gov/vuln/detail/CVE-2024-23452

https://github.com/apache/brpc/commit/ef4ddc644f8f4bf6da1e2a81e763d8e913c340bd

 

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部