【POC 已公开】Oracle WebLogic Server 存在 JNDI 注入漏洞

来源: 投稿
2024-02-07 10:00:00

漏洞描述

Oracle WebLogic Server是一个用于构建、部署和管理企业级Java应用程序。AQjmsInitialContextFactory 是一个允许应用程序使用JNDI查找方式访问Oracle AQ提供消息服务的工厂类。ForeignOpaqueReference是一个对象,lookup时会调用getReferent函数,进行远程对象查询。

该漏洞是 CVE-2023-21839 漏洞绕过,在AQjmsInitialContextFactory初始化时会通过 JNDI获取远程的 DataSource,当通过反射修改 ForeignOpaqueReference 的 jndiEnvironment 和 remoteJNDIName 属性后,再次远程查询ForeignOpaqueReference对象会导致 JNDI 注入,从而直接接管 Oracle WebLogic Server 来执行未经授权的操作或访问系统敏感信息。

漏洞名称 【POC已公开】Oracle WebLogic Server 存在JNDI注入漏洞
漏洞类型 注入
发现时间 2024-02-06
漏洞影响广度 一般
MPS编号 MPS-epi6-f7cb
CVE编号 CVE-2024-20931
CNVD编号 -

影响范围

weblogic_server@[12.2.1.4.0, 12.2.1.4.0]

weblogic_server@[14.1.1.0.0, 14.1.1.0.0]

修复方案

安装官方1月补丁

参考链接

https://www.oscs1024.com/hd/MPS-epi6-f7cb

证明影响版本

 

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部