Jenkins CLI 任意文件读取漏洞导致远程代码执行风险

来源: 投稿
2024-01-25 15:56:00

漏洞描述

Jenkins CLI 是 Jenkins 内置的命令行页面。

Jenkins 受影响版本中使用 args4j 库解析CLI命令参数,该库默认将参数中 @ 字符后的文件路径替换为文件内容,攻击者可利用该特性使用 Jenkins 控制器进程的默认字符编码读取 Jenkins 控制器文件系统上的任意文件(如加密密钥的二进制文件),并结合 Resource Root URL、Remember me cookie、存储型 XSS 或 CSRF 等在 Jenkins 控制器中执行任意代码。

Jenkins 2.442, LTS 2.426.3 版本通过禁用命令解析器读取 @ 字符后文件路径的特性修复此漏洞。

漏洞名称 Jenkins CLI 任意文件读取漏洞导致远程代码执行风险
漏洞类型 路径遍历
发现时间 2024-01-24
漏洞影响广度 一般
MPS编号 MPS-nw0b-89j6
CVE编号 CVE-2024-23897
CNVD编号 -

影响范围

org.jenkins-ci.main:jenkins-core@(-∞, 2.442)

jenkins@(-∞, 2.442)

jenkins lts@(-∞, 2.426.3)

修复方案

将 org.jenkins-ci.main:jenkins-core 升级至 2.442 及以上版本

禁用Jenkins CLI:设置 Java 系统属性 hudson.cli.CLICommand.allowAtSyntax 为 true

将 jenkins 升级至 2.442 及以上版本

将组件 jenkins lts 升级至 2.426.3 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-nw0b-89j6

https://www.jenkins.io/security/advisory/2024-01-24/

https://github.com/jenkinsci/jenkins/commit/de450967f38398169650b55c002f1229a3fcdb1b

https://github.com/jenkinsci/jenkins/commit/554f03782057c499c49bbb06575f0d28b5200edb

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部