Apache Tomcat 信息泄露漏洞

来源: 投稿
2024-01-21 10:20:00

漏洞描述

Apache Tomcat是一个开源Java Servlet容器和Web服务器,用于运行Java应用程序和动态网页。Coyote是Tomcat的连接器,处理来自客户端的请求并将它们传递给Tomcat引擎进行处理。

在受影响的版本中,Coyote.Http11InputBuffer.fill在抛出CloseNowException异常后没有重置缓冲区的position和limit,导致服务端可能可以获取另一个用户的请求数据。攻击者可以通过构造特定请求,在异常页面中输出其他请求的 body 数据。

修复版本中通过增加finally代码块,保证默认会重设缓冲区position和 limit到一致的状态。

漏洞名称 Apache Tomcat 信息泄露漏洞
漏洞类型 通过错误消息导致的信息暴露
发现时间 2024-01-19
漏洞影响广度 一般
MPS编号 MPS-9yx0-38v1
CVE编号 CVE-2024-21733
CNVD编号 -

影响范围

tomcat@[9.0.0-M11, 9.0.44)

tomcat@[8.5.7, 8.5.64)

org.apache.tomcat:tomcat-coyote@[8.5.7, 8.5.64)

org.apache.tomcat:tomcat-coyote@[9.0.0-M11, 9.0.44)

org.apache.tomcat.embed:tomcat-embed-core@[8.5.7, 8.5.64)

org.apache.tomcat.embed:tomcat-embed-core@[9.0.0-M11, 9.0.44)

org.apache.tomcat:tomcat-catalina@[8.5.7, 8.5.64)

org.apache.tomcat:tomcat-catalina@[9.0.0-M11, 9.0.44)

tomcat9@(-∞, 9.0.53-1)

修复方案

将组件 org.apache.tomcat.embed:tomcat-embed-core 升级至 9.0.44 及以上版本

将组件 tomcat9 升级至 9.0.53-1 及以上版本

将组件 org.apache.tomcat:tomcat-catalina 升级至 9.0.44 及以上版本

将组件 tomcat 升级至 9.0.44 及以上版本

将组件 tomcat 升级至 8.5.64 及以上版本

将组件 org.apache.tomcat:tomcat-coyote 升级至 8.5.64 及以上版本

将组件 org.apache.tomcat:tomcat-coyote 升级至 9.0.44 及以上版本

将 rg.apache.tomcat:tomcat-core 升级至 8.5.64 及以上版本

将组件 org.apache.tomcat:tomcat-catalina 升级至 8.5.64 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-9yx0-38v1

https://nvd.nist.gov/vuln/detail/CVE-2024-21733

证明影响版本

Commit

Issue

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部